Bug 127304 - Anaconda and system-setup-packages dont honor dependencies
Anaconda and system-setup-packages dont honor dependencies
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-07-06 08:08 EDT by Sebastian Wenzler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-14 17:04:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
install.log german installation - workstation profile - mozilla working - glibc-devel/gcc problem (54.15 KB, text/plain)
2004-07-06 16:55 EDT, Sebastian Wenzler
no flags Details

  None (edit)
Description Sebastian Wenzler 2004-07-06 08:08:48 EDT
Description of problem:
ive installed fc2 choosing the workstation profile
(iso images from http://wftp.tu-chemnitz.de/index.php?
p=/pub/linux/fedora-core/2/i386/iso/ via ftp)
and custumizing package selection at the end of anacondas package
setup. i added mozilla as a single package. after installation
seemed to have run normally - mozilla didnt start up.
i checked with strace and found that it was missing components
afai remember it was the jscript debugger package.
then i made a clean reinstall of fc2 (no upgrade) and just choose
the workstation setup - using no extra settings
this worked and mozilla was automatically installed with the required
packages. i then checked gnome development, x development and kernel
development in system-setup-packages(?) - meaning the gui thingie
afterwards i tried to compile a simple x application 
this failed as glibc-kernelheaders where missing
after that i installed apt-get from fedora.us
calling apt-get upgrade resulted in a massive list of missing
dependencies. there where devel packages installed that required
the main package to be installed - to name one glade-devel

i have never seen anything like this with a rh distribution
even up2date didnt notice that there was a kernel-sourcecode-2.6.6 
available that obsoletes kernel-source-2.6.5

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
1. reinstall fc2
2. choose workstation setup
3. customize package selection
Actual results:
dependencies are not met

Expected results:
needed packages should be installed

Additional info:
my setup is as follows
amd athlon xp 1500+
elitegroup k7s5a(sis735)
ibm deskstar 307030 ide hdd
asus 875 (sym53c875)
yamaha cdrw 6416 scsi
plextor ultraplex 32 scsi
elsa geforce2mx
Comment 1 Jeremy Katz 2004-07-06 15:24:01 EDT
I haven't seen this here.  Are you sure that mozilla isn't missing the
actual dependency if it requires it?  Please provide your
/root/install.log of where you had problems.
Comment 2 Sebastian Wenzler 2004-07-06 16:53:50 EDT
Yes im sure - as apt-get and rpm itself complains about missing
libraries when installing mozilla on the console

whats makes it a bit more difficult to use s...configpackages is that
after doing up2date and updating several packages,
system-config-packages forgets about the installation of the
kernel-development and other package preselctions
are the versions hardwired in it?

as for the install.log - i can only provide one of the last one where
i got the problem with gcc and glibc

though rpm -q --whatrequires glibc-devel 

it isnt installed with system-config-packages if gcc is selected
for install

can we investigate this further in that direction as i am not very
keen on reinstalling and its seems that the symptoms are the same.
i will surely try to get that done on some weekend by using a free
partition if it is a must.

one thing i forgot - i use german throughout the installation

Comment 3 Sebastian Wenzler 2004-07-06 16:55:24 EDT
Created attachment 101667 [details]
install.log german installation - workstation profile - mozilla working - glibc-devel/gcc problem

Note You need to log in before you can comment on or make changes to this bug.