Bug 1273063 - Vlan table display repeat four times in qmp when queues=4
Vlan table display repeat four times in qmp when queues=4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Vlad Yasevich
weliao
:
Depends On: 1269738
Blocks: 1288337
  Show dependency treegraph
 
Reported: 2015-10-19 09:50 EDT by Vlad Yasevich
Modified: 2016-11-07 15:46 EST (History)
12 users (show)

See Also:
Fixed In Version: qemu-kvm-rhev-2.5.0-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1269738
Environment:
Last Closed: 2016-11-07 15:46:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 weliao 2016-05-17 02:30:55 EDT
Hi Vlad, 
   as you say,It isn't just the vlan table, although it is the mostly obvious one (particularly in rhel7 qemu-kvm package).
   On the surface,I can't reproduce this issue on qemu-kvm-rhev version, so can you tell me how I can verify this bug with qemu-kvm-rhev version?

Thanks
Wei
Comment 3 weliao 2016-09-23 04:14:46 EDT
Reproduce this bug with below version:
qemu-kvm-rhev-2.3.0-23.el7.x86_64
3.10.0-447.el7.x86_64

Test steps:
1.launch a guest with mq
-netdev tap,id=tap0,queues=4,vhost=on  -device virtio-net-pci,netdev=tap0,id=net0,mac=52:54:01:ee:0e:28,bus=pci.0,addr=0x10,mq=on,vectors=10
2.check the rx-filter information without a network name argument.
{"execute":"qmp_capabilities"}
{"return": {}}
{ "execute": "query-rx-filter"}
{"return": [{"promiscuous": true, "name": "net0", "main-mac": "52:54:01:ee:0e:28", "unicast": "normal", "vlan": "all", "vlan-table": [4095, 4094, 4093, 4092, 4091, 4090, 4089, 4088, 4087, 4086, 4085......

Vlan table display repeat four times,so reproduced this bug.
----------------------------------------------------------------------
Verify this bug with below version:
qemu-kvm-rhev-2.6.0-26.el7.x86_64
3.10.0-447.el7.x86_64

the same test steps:
{ "execute": "query-rx-filter"}
{"return": [{"promiscuous": true, "name": "net0", "main-mac": "52:54:01:ee:0e:28", "unicast": "normal", "vlan": "all", "vlan-table": [4095, 4094, 4093, 4092, 4091, 4090, 4089, 4088, 4087......0
Vlan table display only one time.

no repeat display vlan table, So this bug fix well.
Comment 5 errata-xmlrpc 2016-11-07 15:46:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html

Note You need to log in before you can comment on or make changes to this bug.