Bug 1273094 - 4.0: can't remove vm template - the disks are removed and the template stays locked
4.0: can't remove vm template - the disks are removed and the template stays ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Ravi Nori
Ilanit Stein
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 10:40 EDT by Idan Shaby
Modified: 2016-07-05 03:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:59:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: blocker+
rule-engine: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47489 master MERGED engine : Can't remove vm template - the disks are removed and the template stays locked Never

  None (edit)
Description Idan Shaby 2015-10-19 10:40:36 EDT
Description of problem:
When trying to remove a vm template via the webadmin, the disks are removed but the template itself is not removed and its status is stuck as "locked".

Version-Release number of selected component (if applicable):
f439f0f61ffb936d363ab3a0fe4163725ab8aa46

How reproducible:
100%

Steps to Reproduce:
1. Create a vm via the webadmin.
2. Add a disk to the vm.
3. Navigate to the "Templates" tab and try to remove the template.

Actual results:
The template's disk is removed but the template itself doesn't, it's stuck as locked.

Expected results:
The template should be removed.

Additional info:
Comment 1 Tal Nisan 2015-10-19 10:42:56 EDT
Seems like something regarding the end action after the children commands are finished, Moti, can it be related to your recent change?
Comment 2 Arik 2015-10-19 10:59:57 EDT
It seems like this is yet another problem that is caused by Ib3261800f383a6e3973acab4bd16079594fa4149. This change was not merged d/s.

As Tal commented, the end-action is not called when child commands are finished. It happened for us also on hibernate (note that I changed the hibernate command today so it won't reproduce on the hibernate command anymore). When reverting the said patch, the hibernate worked again.

Therefore, moving to infra.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-19 11:02:05 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 4 Tal Nisan 2015-10-19 11:03:14 EDT
OK, good news Arik, so it doesn't interfere with 3.6 then, thanks.
Comment 5 Martin Perina 2016-02-22 04:09:22 EST
Changing severity to low as it's targeted to 4.0
Comment 6 Ilanit Stein 2016-06-15 09:04:06 EDT
Verified on rhevm-4.0.0.2-0.1:

Created a VM.
Added VM a disk
Created a template
Removed the template - successfully
Removed the VM - successfully.
Comment 7 Sandro Bonazzola 2016-07-05 03:59:12 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.