Bug 1273106 - (spice_4k_res) [RFE] SPICE 4K resolution support
[RFE] SPICE 4K resolution support
Status: CLOSED DUPLICATE of bug 1260751
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Scott Herold
Gil Klein
spice
: FutureFeature
: 1210362 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 11:40 EDT by Andrei Stepanov
Modified: 2016-02-10 14:20 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 11:21:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer log (35.09 KB, text/plain)
2015-10-19 11:42 EDT, Andrei Stepanov
no flags Details
qemu-kvm with SPICE_DEBUG_LEVEL=5 (first run) (183.78 KB, text/plain)
2015-10-19 11:44 EDT, Andrei Stepanov
no flags Details
qemu-kvm with SPICE_DEBUG_LEVEL=5 (second run) (222.90 KB, text/plain)
2015-10-19 11:44 EDT, Andrei Stepanov
no flags Details
qemu-kvm with SPICE_DEBUG_LEVEL=5 (qxl video) (48.36 KB, text/plain)
2015-10-19 11:55 EDT, Andrei Stepanov
no flags Details
virt-viewer log (qxl video) (127.96 KB, text/plain)
2015-10-19 11:58 EDT, Andrei Stepanov
no flags Details

  None (edit)
Description Andrei Stepanov 2015-10-19 11:40:00 EDT
virt-viewer with --full-screen parameter on 4k monitor doesn't update resolution of guest VM

virt-viewer v2.0-48 (Windows 7 32)

client's native resolution is: 3840x2160
virt-viewer -f spice:\\xx.xx.xx.xx:3000 -f

It works as expected on the same client/monitor with resolution 1920x1080
Comment 1 Andrei Stepanov 2015-10-19 11:42 EDT
Created attachment 1084446 [details]
virt-viewer log
Comment 2 Andrei Stepanov 2015-10-19 11:44 EDT
Created attachment 1084447 [details]
qemu-kvm with SPICE_DEBUG_LEVEL=5 (first run)
Comment 3 Andrei Stepanov 2015-10-19 11:44 EDT
Created attachment 1084449 [details]
qemu-kvm with SPICE_DEBUG_LEVEL=5 (second run)
Comment 4 Andrei Stepanov 2015-10-19 11:53:39 EDT
Host is:
kernel-3.10.0-323.el7.x86_64
spice-server-0.12.4-15.el7.x86_64

Guest is:
spice-vdagent-0.14.0-10.el7
xorg-x11-drv-qxl-0.1.1-18-el7
Comment 5 Andrei Stepanov 2015-10-19 11:55 EDT
Created attachment 1084452 [details]
qemu-kvm with SPICE_DEBUG_LEVEL=5 (qxl video)
Comment 7 Andrei Stepanov 2015-10-19 11:58 EDT
Created attachment 1084453 [details]
virt-viewer log (qxl video)
Comment 8 Andrei Stepanov 2015-10-19 12:02:57 EDT
Switching from window mode, using menu View->Full Screen also is broken.
Resolutions stays the same as it was for window mode.
Comment 9 Pavel Grunt 2015-10-20 02:17:58 EDT
the client is virt-viewer v2.0-48 (Windows 7 32), changing product & component to rhevm
Comment 10 Pavel Grunt 2015-10-20 02:23:26 EDT
How the VM was created?

Most likely it doesn't have enough memory for the 4k resolution. In that case the RHEL guest fallbacks to the previous used resolution.
Comment 12 Andrei Stepanov 2015-10-20 06:03:46 EDT
Changing from

<model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1'/>

to

<model type='qxl' ram='131072' vram='131072' vgamem='32768' heads='1'/>

-vga qxl -global qxl-vga.ram_size=134217728 -global qxl-vga.vram_size=134217728 -global qxl-vga.vgamem_mb=32

Allows to go in 4k full screen mode
Comment 13 Yaniv Kaul 2015-10-20 06:28:00 EDT
(In reply to Andrei Stepanov from comment #12)
> Changing from
> 
> <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1'/>
> 
> to
> 
> <model type='qxl' ram='131072' vram='131072' vgamem='32768' heads='1'/>
> 
> -vga qxl -global qxl-vga.ram_size=134217728 -global
> qxl-vga.vram_size=134217728 -global qxl-vga.vgamem_mb=32
> 
> Allows to go in 4k full screen mode

Was it tested? What's the overall performance of a VM with more graphics memory? What's the graphics performance?
Can it be migrated, for example?
Comment 17 Yaniv Lavi 2015-10-28 10:41:00 EDT
*** Bug 1210362 has been marked as a duplicate of this bug. ***
Comment 18 Yaniv Kaul 2015-11-26 11:21:07 EST

*** This bug has been marked as a duplicate of bug 1260751 ***

Note You need to log in before you can comment on or make changes to this bug.