Bug 1273112 - First attempt to log out fails
First attempt to log out fails
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
23
All All
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedFreezeException RejectedBlock...
: CommonBugs
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-19 11:55 EDT by Adam Williamson
Modified: 2016-12-20 10:04 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 10:04:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journal from an affected boot (485.64 KB, text/plain)
2015-10-19 12:26 EDT, Adam Williamson
no flags Details
updated journal (23 Final RC2) (399.52 KB, text/plain)
2015-10-21 14:52 EDT, Adam Williamson
no flags Details
my journalctl (23 Final RC2) (444.62 KB, text/plain)
2015-10-21 16:48 EDT, Giulio 'juliuxpigface'
no flags Details

  None (edit)
Description Adam Williamson 2015-10-19 11:55:51 EDT
I've been able to repeat this one quite reliably:

* Clean install of a recent F23 Final Workstation live (TC9, TC10, TC11)
* Boot installed system
* Create user in gnome-initial-setup
* Get to desktop as that user
* Try to log out

Instead of logging me out it just blanks the screen briefly then returns to the logged-in desktop. A second attempt to log out either works or hits https://bugzilla.redhat.com/show_bug.cgi?id=1272737 .
Comment 1 Adam Williamson 2015-10-19 12:26 EDT
Created attachment 1084456 [details]
journal from an affected boot

This is a journal from an affected boot. It's the first boot after install; it includes g-i-s user creation, then login, then the first logout attempt fails with this bug. Note: I then went out and tried to log out two more times, as I was working on other bugs too. The first logout attempt is the one relevant to this bug.
Comment 2 Adam Williamson 2015-10-21 14:52 EDT
Created attachment 1085268 [details]
updated journal (23 Final RC2)

Still happens with 23 Final RC2; attaching updated journal, this time with only this bug in it (no subsequent logout/login attempts). I *did* see the distinctive 'pebbled grey' GDM background very briefly. When I click 'log out' what actually happens is the screen goes blank briefly, then comes back to the desktop - just between the blank screen and the desktop I briefly saw a flash of the GDM background, it seemed.
Comment 3 Adam Williamson 2015-10-21 14:56:09 EDT
I guess this is technically a violation of "Shutting down, logging out and rebooting must work using standard console commands and the mechanisms offered (if any) by all release-blocking desktops." - https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Shutdown.2C_reboot.2C_logout - when installing Workstation and just for the first logout. I'd probably be inclined to -1 and CommonBugs it, but we should at least discuss it.
Comment 4 John Dulaney 2015-10-21 16:17:19 EDT
I just hit this with TC2 workstation x86_64
Comment 5 Adam Williamson 2015-10-21 16:27:18 EDT
Hmm, in fact, it seems it logs you out and automatically logs you back in. I just hit it again, and I had a console open; when it came back to the desktop, the console was gone.

Oooh!

I wonder if this is related to https://bugzilla.redhat.com/show_bug.cgi?id=1272706 somehow? The session that g-i-s tries to set up when you finish it instead is somehow 'kicking in' after you first log out?
Comment 6 Giulio 'juliuxpigface' 2015-10-21 16:48 EDT
Created attachment 1085327 [details]
my journalctl (23 Final RC2)
Comment 7 Giulio 'juliuxpigface' 2015-10-21 16:48:59 EDT
Reproduced here on the first login, with TC2 workstation x86_64 on a qemu-kvm guest.

Additionally, I noticed some details:
1) After hitting the bug, I switched to another VT with Ctrl+Alt+F3 in order to retrieve journalctl's log.
2) Then, I've tried to switch back and the virtual screen "freezed". I issued a reboot via virt-manager.
3) I'm hitting this on every boot, don't know if it may be related or not: https://bugzilla.redhat.com/show_bug.cgi?id=1259985.
Comment 8 Adam Williamson 2015-10-21 17:18:17 EDT
so yeah, I just did an install creating a user in anaconda instead of in g-i-s, and the first log out attempt worked.
Comment 9 Adam Williamson 2015-10-21 19:16:37 EDT
OK, yeah, seems like it's definitely caused by 1272706. Every time I hit that bug - i.e. after creating a user in g-i-s I get sent to GDM, not to a logged-in desktop - I also hit this bug: when I log out, I'm immediately logged back in. Any time I *don't* hit that bug, I don't hit this bug either: the first logout works.

So I suspect what's happening is some kinda race. g-i-s tries to start up a session as the user you just created, but it doesn't do it fast enough or does it too fast or something(?), and GDM comes up. You log in manually. When you log out, the session g-i-s was trying to start up 'kicks in' somehow. I'll poke about at the code a bit, but probably a dev is more likely able to spot the cause of this than me.

FWIW, I hit the two bugs testing both in a KVM and on bare metal almost all the time (think once or twice I got lucky). I managed to get a successful g-i-s to session transition only by adding 'nomodeset', as suggested by kalev, in a VM boot.
Comment 10 Adam Williamson 2015-10-22 12:45:05 EDT
Discussed at 2015-10-22 Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2015-10-22/f23-final-go_no_go-meeting.2015-10-22-16.00.log.txt . As this is a one-time bug and easy to document (though it's bad from a polish perspective) this was rejected as a blocker, but it was accepted as a freeze exception because, indeed, it's pretty bad OOTB polish and we should fix it if possible.
Comment 11 Christian Stadelmann 2016-09-22 14:26:27 EDT
I've also seen this on F25 alpha when gnome-settings-daemon wasn't reacting to any IPC due to bug #1366775.
Comment 12 Fedora End Of Life 2016-11-24 07:50:45 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 13 Fedora End Of Life 2016-12-20 10:04:05 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.