Bug 1273131 - clGetPlatformIDs causes futex race condition
clGetPlatformIDs causes futex race condition
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
23
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 13:27 EDT by bob
Modified: 2016-02-07 13:31 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-07 13:31:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Blender GDB backtrace (3.94 KB, text/plain)
2015-10-19 13:29 EDT, bob
no flags Details

  None (edit)
Description bob 2015-10-19 13:27:50 EDT
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build Identifier: 

Apologies if I've mischaracterised anything above, I'm going off of my uninformed analysis of the attached backtrace from GDB.

Attempting to use Blender in any meaningful way results in the UI hanging. strace clued me into the blocking futex call and gdb seems to point the finger at libOpenCL.so. 

Oddly enough, clinfo works as it should

Reproducible: Always

Steps to Reproduce:
1. Open Blender
2. Open system tab of preferences panel, switch to the Cycles renderer etc
Actual Results:  
UI freeze, application hang

Expected Results:  
Application doesn't hang

rpm -q fedora-release
fedora-release-23-0.17.noarch

rpm -q blender       
blender-2.75-4.fc23.x86_64

rpm -q ocl-icd
ocl-icd-2.2.7-2.git20150606.ebbc4c1.fc23.x86_64
Comment 1 bob 2015-10-19 13:29 EDT
Created attachment 1084465 [details]
Blender GDB backtrace
Comment 2 Fabian Deutsch 2015-10-20 04:04:09 EDT
The backtrace shows that clover is used.
Comment 3 bob 2015-10-25 08:37:48 EDT
I've tried with a variety of different configurations to check whether this bug might be setup-specific. I normally use two GPUs from mixed vendors, but I tried using a single GTX570, HD6870, HD6950, 9800GT and just the plain Intel HD4000 but still this bug persists
Comment 4 Fabian Deutsch 2016-02-07 13:31:39 EST
I strongly suspect that it's an issue if clover/mesa's opencl tracker, please file a bug in upstream or retry with the latest release from rawhide.

Note You need to log in before you can comment on or make changes to this bug.