Bug 1273145 - TypeError: 'str' does not support the buffer interface
TypeError: 'str' does not support the buffer interface
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:2f56dbdc8a5ba024954b243a629...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 14:24 EDT by Stephen Gallagher
Modified: 2015-11-02 10:37 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-24.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 10:37:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (366.29 KB, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: anaconda.log (20.03 KB, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: dnf.log (759 bytes, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: environ (459 bytes, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: ks.cfg (595 bytes, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: lsblk_output (2.33 KB, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: nmcli_dev_list (1.25 KB, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: os_info (451 bytes, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: program.log (66.86 KB, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: storage.log (88.33 KB, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: syslog (62.33 KB, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: ifcfg.log (1.94 KB, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details
File: packaging.log (679 bytes, text/plain)
2015-10-19 14:24 EDT, Stephen Gallagher
no flags Details

  None (edit)
Description Stephen Gallagher 2015-10-19 14:24:31 EDT
Description of problem:
I attempted to install via a kickstart that joins a FreeIPA domain at the same time.

Version-Release number of selected component:
anaconda-23.19.7-1

The following was filed automatically by anaconda:
anaconda 23.19.7-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 545, in setup
    lines = output.split("\n")
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 208, in doInstall
    ksdata.realm.setup()
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: 'str' does not support the buffer interface

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-23_T11-x86_64 quiet inst.ks=http://sgallagh.fedorapeople.org/kickstarts/f23/ipa.ks
dnf.rpm.log:    Oct 19 18:11:27 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Stephen Gallagher 2015-10-19 14:24:35 EDT
Created attachment 1084474 [details]
File: anaconda-tb
Comment 2 Stephen Gallagher 2015-10-19 14:24:37 EDT
Created attachment 1084475 [details]
File: anaconda.log
Comment 3 Stephen Gallagher 2015-10-19 14:24:38 EDT
Created attachment 1084476 [details]
File: dnf.log
Comment 4 Stephen Gallagher 2015-10-19 14:24:39 EDT
Created attachment 1084477 [details]
File: environ
Comment 5 Stephen Gallagher 2015-10-19 14:24:40 EDT
Created attachment 1084478 [details]
File: ks.cfg
Comment 6 Stephen Gallagher 2015-10-19 14:24:41 EDT
Created attachment 1084479 [details]
File: lsblk_output
Comment 7 Stephen Gallagher 2015-10-19 14:24:42 EDT
Created attachment 1084480 [details]
File: nmcli_dev_list
Comment 8 Stephen Gallagher 2015-10-19 14:24:43 EDT
Created attachment 1084481 [details]
File: os_info
Comment 9 Stephen Gallagher 2015-10-19 14:24:45 EDT
Created attachment 1084482 [details]
File: program.log
Comment 10 Stephen Gallagher 2015-10-19 14:24:47 EDT
Created attachment 1084483 [details]
File: storage.log
Comment 11 Stephen Gallagher 2015-10-19 14:24:48 EDT
Created attachment 1084484 [details]
File: syslog
Comment 12 Stephen Gallagher 2015-10-19 14:24:49 EDT
Created attachment 1084485 [details]
File: ifcfg.log
Comment 13 Stephen Gallagher 2015-10-19 14:24:50 EDT
Created attachment 1084486 [details]
File: packaging.log
Comment 14 Fedora Blocker Bugs Application 2015-10-19 14:28:09 EDT
Proposed as a Blocker for 23-final by Fedora user sgallagh using the blocker tracking app because:

 Alpha Criterion:
"It must be possible to join the system to a FreeIPA or Active Directory domain at install time and post-install, and the system must respect the identity, authentication and access control configuration provided by the domain."
Comment 15 Adam Williamson 2015-10-19 16:12:04 EDT
This doesn't depend on #1273167. Fixing #1273167 would *hide* (this case of) bug, but this bug can be fixed without #1273167 being fixed.

Transferring blocker nomination to 1273167. The anaconda part of this isn't really a major issue, just anaconda should error gracefully when 'realm discover' fails rather than crashing somewhat cryptically. That's not release blocker stuff.

Note You need to log in before you can comment on or make changes to this bug.