Bug 1273146 - Include a wayland app launching fix for F23
Include a wayland app launching fix for F23
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-19 14:32 EDT by Kalev Lember
Modified: 2015-10-26 17:02 EDT (History)
4 users (show)

See Also:
Fixed In Version: glib2-2.46.1-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 17:02:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kalev Lember 2015-10-19 14:32:34 EDT
Upstream is asking me to include a fix which makes app launching work under Wayland. As Wayland support in Fedora is getting quite a bit of exposure in media, might be worth pulling it in for the live images.

< ebassi> It's already been cherry-picked to the stable branch, but that patch makes it possible to launch X11 apps on Wayland when clicking on buttons or terminal URLs

https://git.gnome.org/browse/glib/commit/?h=glib-2-46&id=24a4b33ffe7f4ef3487316e85060dd37b907941d
Comment 1 Emmanuele Bassi 2015-10-19 14:42:51 EDT
If any application is launching an application still using X11, without this patch the operation will fail because the DISPLAY environment variable is pointing to the wrong value.

This affects all applications using GIO or GTK API to launch applications — for instance, the terminal when clicking on an URL, or double-clicking on a file in Nautilus.
Comment 2 Stephen Gallagher 2015-10-19 14:45:11 EDT
Is this a fix for the 'sudo gvim' and similar problems under Wayland?
Comment 3 Adam Williamson 2015-10-19 16:14:52 EDT
Discussed at 2015-10-19 freeze exception review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-19/f23-blocker-review.2015-10-19-16.00.html . Rejected as a freeze exception issue: this would clearly be a nice fix, and we take the point that people may test Wayland immediately after installation without updating the system, but changing glib this close to release just seems like too high a risk for this non-default path. Last week we may have taken it, but not now.
Comment 4 Fedora Update System 2015-10-19 17:40:05 EDT
glib2-2.46.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f95b0c8f45
Comment 5 Fedora Update System 2015-10-20 17:58:12 EDT
glib2-2.46.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update glib2'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f95b0c8f45
Comment 6 Emmanuele Bassi 2015-10-21 11:38:10 EDT
Just tested glib2-2.46.1-2 from updates-testing, and can confirm that it fixes the issue of launching X11 apps under Wayland from GLib-based applications.
Comment 7 Kalev Lember 2015-10-22 08:30:18 EDT
Reproposing as a Freeze Exception. We agreed in the blocker meeting that it would be nice to pull this in if we end up slipping, and it looks a lot like we are going to slip for a week.
Comment 8 Adam Williamson 2015-10-22 13:58:26 EDT
Discussed at 2015-10-22 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-22/f23-fe-review.2015-10-22-17.30.log.txt . Accepted as a freeze exception issue: since we're slipping, we were OK with pulling this in for an RC composed soon, as we'd have time to back it out if it turns out to be busted.
Comment 9 Fedora Update System 2015-10-26 17:02:09 EDT
glib2-2.46.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.