Bug 1273173 - Need update documents for queue_without_daemon option of multipath as its default value changed.
Summary: Need update documents for queue_without_daemon option of multipath as its def...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.3
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Lin Li
URL:
Whiteboard:
Keywords:
Depends On: 818404
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-19 20:36 UTC by Ben Marzinski
Modified: 2016-11-04 08:13 UTC (History)
12 users (show)

(edit)
documentation fix. No Doc Text necessary
Clone Of: 818404
(edit)
Last Closed: 2016-11-04 08:13:55 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2536 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2016-11-03 14:18:10 UTC

Comment 2 Ben Marzinski 2016-02-26 21:27:22 UTC
Updated the man page and multipath.conf.defaults

Comment 5 Lin Li 2016-04-26 01:39:48 UTC
Reproduced on device-mapper-multipath-0.4.9-85.el7
1).# man multipath.conf 
      queue_without_daemon
                        If set to no , when multipathd stops, queueing will be
                        turned off  for  all  devices.   This  is  useful  for
                        devices  that set no_path_retry.  If a machine is shut
                        down while all paths to a device are down, it is  pos‐
                        sible to hang waiting for IO to return from the device
                        after multipathd has been stopped. Without  multipathd
                        running,  access  to the paths cannot be restored, and
                        the kernel cannot be told to stop queueing IO. Setting
                        queue_without_daemon  to  no  ,  avoids  this problem.
                        Default is yes       <-------------------
2).# multipathd -k'show config' | grep queue_without_daemon
	queue_without_daemon "no"
3).# multipathd show config | grep queue_without_daemon
	queue_without_daemon "no"
4).# multipath -t | grep queue_without_daemon
	queue_without_daemon "no"


Verified on  device-mapper-multipath-0.4.9-87.el7
1).# man multipath.conf 
       queue_without_daemon
                        If set to no , when multipathd stops, queueing will be
                        turned off  for  all  devices.   This  is  useful  for
                        devices  that set no_path_retry.  If a machine is shut
                        down while all paths to a device are down, it is  pos‐
                        sible to hang waiting for IO to return from the device
                        after multipathd has been stopped. Without  multipathd
                        running,  access  to the paths cannot be restored, and
                        the kernel cannot be told to stop queueing IO. Setting
                        queue_without_daemon  to  no  ,  avoids  this problem.
                        Default is no    <-------------------
2).# multipathd -k'show config' | grep queue_without_daemon
	queue_without_daemon "no"
3).# multipathd show config | grep queue_without_daemon
	queue_without_daemon "no"
4).# multipath -t | grep queue_without_daemon
	queue_without_daemon "no"


Test result: man page of multipath.conf change default value of queue_without_daemon to "queue_without_daemon no"

Comment 8 errata-xmlrpc 2016-11-04 08:13:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html


Note You need to log in before you can comment on or make changes to this bug.