Bug 1273197 - VXLAN should be default neutron network type
VXLAN should be default neutron network type
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: rdo-manager-cli (Show other bugs)
unspecified
Unspecified Unspecified
high Severity unspecified
: ---
: Liberty
Assigned To: Ana Krivokapic
Shai Revivo
:
Depends On: 1244864
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 18:13 EDT by Alexander Chuzhoy
Modified: 2017-06-18 02:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1244864
Environment:
Last Closed: 2017-06-18 02:24:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2015-10-19 18:13:47 EDT
Description of problem:
In RDO, the default network type is GRE. We should change this to VXLAN for several reasons: VXLAN has better performance (20-25% better); NICs with VXLAN offload are more common.


How reproducible:
100%

Steps to Reproduce:
Deploy overcloud with RDO without specifying a network type

Actual results:
GRE is the default

Expected results:
VXLAN should be the default
Comment 1 Mike Burns 2015-10-20 06:53:45 EDT
This is due to python-tripleoclient not having this patch:

https://review.openstack.org/#/c/224870/

It's overriding the default in tripleo-heat-templates.  You can see the default in THT in /usr/share/openstack-tripleo-heat-templates/puppet/controller.yaml
Comment 2 Mike McCune 2016-03-28 18:14:36 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Christopher Brown 2017-06-17 13:21:04 EDT
vxlan is now the default so this can be closed.

Note You need to log in before you can comment on or make changes to this bug.