Bug 1273246 - Tier xattr name is misleading (trusted.tier-gfid)
Tier xattr name is misleading (trusted.tier-gfid)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
:
Depends On: 1259298
Blocks: 1273249 glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-10-19 23:47 EDT by Nithya Balachandran
Modified: 2015-11-17 01:01 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1259298
: 1273249 (view as bug list)
Environment:
Last Closed: 2015-11-17 01:01:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-10-19 23:47:19 EDT
+++ This bug was initially created as a clone of Bug #1259298 +++

Description of problem:
The trusted.tier-gfid xattr does not actually store a gfid.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-10-13 07:51:37 EDT ---

REVIEW: http://review.gluster.org/12350 (cluster/tier: Changed tier xattr-name value) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-14 01:31:50 EDT ---

REVIEW: http://review.gluster.org/12350 (cluster/tier: Changed tier xattr-name value) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-19 09:06:29 EDT ---

COMMIT: http://review.gluster.org/12350 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 0243085e40d842c59f4d7d59c61701ba416878ec
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Oct 13 17:11:29 2015 +0530

    cluster/tier: Changed tier xattr-name value
    
    Each tier layer (for future stacking implementations)
    must have a unique xattr name. We are currently using
    the name of the tier subvolume excluding the volume name.
    
    Change-Id: Id4adea61dc1c8473fb1d4d7364d1940278c6e129
    BUG: 1259298
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12350
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 1 Vijay Bellur 2015-10-19 23:53:59 EDT
REVIEW: http://review.gluster.org/12398 (cluster/tier: Changed tier xattr-name value) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2015-10-20 13:12:58 EDT
REVIEW: http://review.gluster.org/12398 (cluster/tier: Changed tier xattr-name value) posted (#2) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 3 Vijay Bellur 2015-10-20 21:39:33 EDT
COMMIT: http://review.gluster.org/12398 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 3ef95b2707a55b4995cf5607ee8d20d76081024e
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Oct 20 09:18:10 2015 +0530

    cluster/tier: Changed tier xattr-name value
    
    Each tier layer (for future stacking implementations)
    must have a unique xattr name. We are currently using
    the name of the tier subvolume excluding the volume name.
    
    Change-Id: Id4adea61dc1c8473fb1d4d7364d1940278c6e129
    BUG: 1273246
    >Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/12350
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    (cherry picked from commit 0243085e40d842c59f4d7d59c61701ba416878ec)
    Signed-off-by: Nithya Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12398
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Raghavendra Talur 2015-11-17 01:01:01 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.