Bug 1273265 - Persistent Volume isolation in Openshift
Persistent Volume isolation in Openshift
Status: CLOSED DUPLICATE of bug 1276082
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Mike Barrett
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 01:43 EDT by Jaspreet Kaur
Modified: 2016-01-12 16:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-12 16:04:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaspreet Kaur 2015-10-20 01:43:42 EDT
1. What is the nature and description of the request?  

   Persistent volume isolation is required.
      
2. Why does the customer need this? (List the business requirements here)  

    At present anyone can mount nfs volumes of each project and that is a problem: we don't want that people of a project can read the data of other projects. For eg:

1) we populate persistent volumes as cluster admin and then the users claim these ones.
2) the users of other project directly mount a NFS resource.
      
3. How would the customer like to achieve this? (List the functional requirements here)
    
   More permission on NFS or added security to the persistent volume claimed by a project.
      
4. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  

    Confirm functionality as expected. 

5. Is there already an existing RFE upstream or in Red Hat Bugzilla?  

none found

6. Does the customer have any specific timeline dependencies and which release would they like to target?

The ideal timeline is for the end of this year so we can use the NFS with isolation for the next year in production.
      
      
7. List any affected packages or components.  

N/A
      
8. Would the customer be able to assist in testing this functionality if implemented?  

yes
Comment 4 Ryan Howe 2016-01-12 16:04:16 EST

*** This bug has been marked as a duplicate of bug 1276082 ***

Note You need to log in before you can comment on or make changes to this bug.