Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1273280 - [fr, pt_BR, ru, kon_KR, zh_TW][evince] Translation incomplete
Summary: [fr, pt_BR, ru, kon_KR, zh_TW][evince] Translation incomplete
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evince
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Martin Hatina
QA Contact: Engineering Localization bugs mailing list
URL:
Whiteboard:
Depends On:
Blocks: 1262678 1313485 1340415
TreeView+ depends on / blocked
 
Reported: 2015-10-20 06:58 UTC by Bhushan Barve
Modified: 2016-11-03 23:43 UTC (History)
12 users (show)

Fixed In Version: evince-3.14.2-17.el7
Doc Type: Bug Fix
Doc Text:
Cause: Some messages are not translated. Consequence: Translations for evince falls under FAIL-4 and FAIL-5 categories. Fix: Messages are translated. Result: Bug doesn't occur anymore.
Clone Of:
Environment:
Last Closed: 2016-11-03 23:43:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
FAIL category definition document (15.53 KB, application/vnd.oasis.opendocument.graphics)
2015-10-20 06:58 UTC, Bhushan Barve
no flags Details
Translations patch for rhel-7.3 branch (299.88 KB, patch)
2016-03-14 05:51 UTC, Parag Nemade
no flags Details | Diff
Translations patch for remaining ko language (3.33 KB, patch)
2016-06-21 11:24 UTC, Parag Nemade
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2164 0 normal SHIPPED_LIVE evince bug fix update 2016-11-03 13:14:51 UTC

Description Bhushan Barve 2015-10-20 06:58:36 UTC
Created attachment 1084619 [details]
FAIL category definition document

Description of problem: As reported by the translators in the l10n qa event, translations for this package falls under FAIL-4 and FAIL-5  Categories.


Version-Release number of selected component (if applicable):
evince-3.14.2-5.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.NA
2.
3.

Actual results:
Translations are not completed.

Expected results:
Translation should be completed 100% and be pulled and build in the package in order to reflect the translation work done in UI/CLI.

Additional info:
FAIL Categories are defined by l10n team lead, and the file is attached with this bug.

Comment 2 Noriko Mizumoto 2016-01-15 03:18:32 UTC
Could you please provide the translation stats?

Comment 3 Krishna Babu K 2016-01-15 11:29:40 UTC
branch: * rhel-7.3
Name:           evince
Version:        3.14.2
Release:        5%{?dist}
 
./evince.pot: 0 translated messages, 368 untranslated messages.

Translated LANGs:
./de.po: 355 translated messages.
./es.po: 355 translated messages.
./fr.po: 355 translated messages.
./it.po: 355 translated messages.
./ko.po: 355 translated messages.
./pt_BR.po: 355 translated messages.
./ru.po: 355 translated messages.
./zh_CN.po: 355 translated messages.
./zh_TW.po: 355 translated messages.
 
Fuzzy LANGs:
./ja.po: 351 translated messages, 1 fuzzy translation, 3 untranslated messages.
 
Untranslated LANGs:
./ja.po: 351 translated messages, 1 fuzzy translation, 3 untranslated messages.

Comment 4 Noriko Mizumoto 2016-01-19 01:11:46 UTC
Krishna,
Could you please refer to the comment #15 of the bug #1221520 by Milan, and regenerate with intltool-update?

Comment 5 sandeep shedmake 2016-01-19 15:58:54 UTC
From Comment 4,

branch: * rhel-7.3
Name:           evince
Version:        3.14.2
Release:        5%{?dist}


./evince.pot: 0 translated messages, 368 untranslated messages.
 
./de.po: 368 translated messages.
./es.po: 368 translated messages.
./fr.po: 355 translated messages, 13 untranslated messages.
./it.po: 368 translated messages.
./ja.po: 364 translated messages, 1 fuzzy translation, 3 untranslated messages.
./ko.po: 355 translated messages, 13 untranslated messages.
./pt_BR.po: 355 translated messages, 13 untranslated messages.
./ru.po: 355 translated messages, 13 untranslated messages.
./zh_CN.po: 368 translated messages.
./zh_TW.po: 368 translated messages.

Comment 6 Noriko Mizumoto 2016-01-20 03:15:52 UTC
[RHEL 7.3] Assigned to Jens for RHEL7.3 localization preparation.

Comment 7 Parag Nemade 2016-03-14 05:51:53 UTC
Created attachment 1136032 [details]
Translations patch for rhel-7.3 branch

Comment 8 Marek Kašík 2016-03-29 15:29:54 UTC
Thank you for the patch Parag.
Martin, could you push it to corresponding repository?

Comment 11 Parag Nemade 2016-06-21 11:24:22 UTC
Created attachment 1170221 [details]
Translations patch for remaining ko language

Comment 13 sandeep shedmake 2016-06-23 11:01:50 UTC
From Comment 11 and Comment 12,

Tested 'evince-3.14.2-EL7.3_translations_for_ko.patch' i.e. attachment #1170221 [details]

Post applying the above patch, following translation statistics are obtained:

de: 368 translated messages.
es: 368 translated messages.
fr: 368 translated messages.
it: 368 translated messages.
ja: 368 translated messages.
ko: 368 translated messages.
pt_BR: 368 translated messages.
ru: 368 translated messages.
zh_CN: 368 translated messages.
zh_TW: 368 translated messages.


From above:
- With above patch, Italian (it) and Korean (ko) are now 100% translated
- Required rhel-7.3 languages are 100% translated


Thereby, requesting devel to incorporate the above patch in the forthcoming build towards effective resolution of the bug.

Comment 14 Satyabrata Maitra 2016-06-29 05:23:59 UTC
Hi Devel

Requesting to please provide the latest build applying the patch that fixes the translations and put the bug on ON_QA status.

Regards
Satya

Comment 15 Martin Hatina 2016-06-29 07:26:27 UTC
Hi Commentator,

due to connectivity issues I wasn't able to prepare build with the patch yesterday,
but I managed to build it today.

Regards,
Devel

Comment 18 errata-xmlrpc 2016-11-03 23:43:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2164.html


Note You need to log in before you can comment on or make changes to this bug.