Bug 1273292 - /etc/corosync/corsync.conf file missing after multiple nfs-ganesha disable/enable
/etc/corosync/corsync.conf file missing after multiple nfs-ganesha disable/en...
Status: CLOSED DUPLICATE of bug 1273288
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 03:19 EDT by Apeksha
Modified: 2015-10-20 03:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 03:21:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Apeksha 2015-10-20 03:19:01 EDT
Description of problem:
/etc/corosync/corsync.conf file missing after multiple nfs-ganesha disable/enable, due to which not able to setup the ganesha cluster

Version-Release number of selected component (if applicable):
nfs-ganesha-2.2.0-9.el7rhgs.x86_64
glusterfs-3.7.5-0.3.el7rhgs.x86_64

How reproducible:
Twice

Steps to Reproduce:
1. Multiple times executing gluster nfs-ganesha enable/disable
2. /etc/corosync/corsync.conf file is missing

/var/log/messages:
Oct 20 12:45:24 dhcp35-194 systemd: Started PCS GUI and remote configuration interface.
Oct 20 12:45:24 dhcp35-194 systemd: Starting Corosync Cluster Engine...
Oct 20 12:45:24 dhcp35-194 corosync[24640]: [MAIN  ] Can't read file /etc/corosync/corosync.conf reason = (No such file or directory)
Oct 20 12:45:24 dhcp35-194 corosync[24640]: [MAIN  ] Corosync Cluster Engine exiting with status 8 at main.c:1207.
Oct 20 12:45:24 dhcp35-194 corosync: Starting Corosync Cluster Engine (corosync): [FAILED]
Oct 20 12:45:24 dhcp35-194 systemd: corosync.service: control process exited, code=exited status=1
Oct 20 12:45:24 dhcp35-194 systemd: Failed to start Corosync Cluster Engine.
Oct 20 12:45:24 dhcp35-194 systemd: Dependency failed for Pacemaker High Availability Cluster Manager.
Oct 20 12:45:24 dhcp35-194 systemd: 
Oct 20 12:45:24 dhcp35-194 systemd: Unit corosync.service entered failed state.
Oct 20 12:45:24 dhcp35-194 systemd: Starting NFS status monitor for NFSv2/3 locking....
Oct 20 12:45:24 dhcp35-194 rpc.statd: Statd service already running!
Oct 20 12:45:24 dhcp35-194 systemd: nfs-ganesha-lock.service: control process exited, code=exited status=1
Oct 20 12:45:24 dhcp35-194 systemd: Failed to start NFS status monitor for NFSv2/3 locking..
Oct 20 12:45:24 dhcp35-194 systemd: Unit nfs-ganesha-lock.service entered failed state.
Oct 20 12:45:24 dhcp35-194 systemd: Started NFS-Ganesha file server.
Oct 20 12:46:01 dhcp35-194 systemd: Starting Session 1784 of user root.
Oct 20 12:46:01 dhcp35-194 systemd: Started Session 1784 of user root.
Oct 20 12:46:28 dhcp35-194 systemd: Starting NFS status monitor for NFSv2/3 locking....
Oct 20 12:46:28 dhcp35-194 rpc.statd: Statd service already running!
Oct 20 12:46:28 dhcp35-194 systemd: nfs-ganesha-lock.service: control process exited, code=exited status=1
Oct 20 12:46:28 dhcp35-194 systemd: Failed to start NFS status monitor for NFSv2/3 locking..
Oct 20 12:46:28 dhcp35-194 systemd: Unit nfs-ganesha-lock.service entered failed state.

Actual results: /etc/corosync/corsync.conf file is missing


Expected results: /etc/corosync/corsync.conf file should not be missing


Additional info:
Comment 2 Apeksha 2015-10-20 03:21:49 EDT

*** This bug has been marked as a duplicate of bug 1273288 ***

Note You need to log in before you can comment on or make changes to this bug.