Bug 1273303 - [RFE] add enable_isolated_metadata neutron parameter
[RFE] add enable_isolated_metadata neutron parameter
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity low
: ---
: 8.0 (Liberty)
Assigned To: Jiri Stransky
Amit Ugol
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 03:48 EDT by Cyril Lopez
Modified: 2018-01-21 10:10 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-5.el7ost
Doc Type: Enhancement
Doc Text:
The Director now supports the OpenStack Networking 'enable_isolated_metadata' option. This option allows access to instance metadata on VMs on external routers or on isolated networks.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:41:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 237464 None None None Never

  None (edit)
Description Cyril Lopez 2015-10-20 03:48:07 EDT
Description of problem:
In case of spawn a VM directly on a provider network, metadata can't provide cloud-init cause VM go thru on external router. We need to set true enable_isolated_metadata in /etc/neutron/dhcp_agent.ini

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-71.el7ost.noarch

How reproducible:
Install openstack-tripleo-heat-templates, no parameter is setup-able for enable_isolated_metadata

Steps to Reproduce:
1. Install undercloud
2. Check into template


Actual results:


Expected results:
NeutronEnableIsolatedMetadata: could be a param into our environement

Additional info:
Comment 2 Cyril Lopez 2015-10-20 04:53:53 EDT
This upstream patch add the feature https://review.openstack.org/#/c/237464/
Comment 3 Emilien Macchi 2015-12-01 16:44:47 EST
The patch has been merged upstream, I guess we need to backport it to OSP7.
Comment 10 errata-xmlrpc 2016-04-07 17:41:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.