Bug 1273309 - zonemgr email id should be checked before installation starts
zonemgr email id should be checked before installation starts
Status: CLOSED DUPLICATE of bug 1278330
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 03:57 EDT by Abhijeet Kasurde
Modified: 2015-11-05 04:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 04:53:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
zonemgr_console.log (7.09 KB, text/plain)
2015-10-20 03:59 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Abhijeet Kasurde 2015-10-20 03:57:31 EDT
Description of problem:
If user specify command like 

ipa-server-install --setup-dns --forwarder=102.102.160.2  -r TESTRELM.TEST -p password -a password --zonemgr=Têko@redhat.com -U

installation goes on and while installation steps of DNS, it fails with error like following

<snip>

Configuring DNS (named)
  [1/12]: generating rndc key file
  [2/12]: adding DNS container
  [3/12]: setting up our zone
  [error] ConversionError: invalid 'admin_email': domain name 'Têko.redhat.com' should be normalized to: tãako.redhat.com
ipa.ipapython.install.cli.install_tool(Server): ERROR    invalid 'admin_email': domain name 'Têko.redhat.com' should be normalized to: tãako.redhat.com

</snip>

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-15.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start fresh installation of IPA server with zonemgr option and unicode string as argument.

Actual results:
Installation fails at DNS configuration phase with 
ERROR    invalid 'admin_email': domain name 'Têko.redhat.com' should be normalized to: tãako.redhat.com

Expected results:
Installation should check before start and warn user beforehand.

Additional info:
Related to 
1. https://fedorahosted.org/freeipa/ticket/4771
2. https://bugzilla.redhat.com/show_bug.cgi?id=1163849
Comment 1 Abhijeet Kasurde 2015-10-20 03:59 EDT
Created attachment 1084647 [details]
zonemgr_console.log
Comment 3 Martin Bašti 2015-10-20 04:17:41 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5386
Comment 7 Petr Vobornik 2015-11-05 04:53:06 EST

*** This bug has been marked as a duplicate of bug 1278330 ***

Note You need to log in before you can comment on or make changes to this bug.