Bug 127331 - Now not possible to vnc into desktop of user with desktop open in another session.
Now not possible to vnc into desktop of user with desktop open in another ses...
Status: CLOSED DUPLICATE of bug 125256
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-06 14:29 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-07-06 14:29:13 EDT
Description of problem:

  It actually is _almost_ possible to start a vncserver session which
is the same as a direct connected user.

The screen itself shows different things (ok), but the two sessions
share desktop config files (this is ok), but there seems to be a lock
on Font files.

The session instantiated later has only default fonts displayed. As
soon as the earlier instantiation is ended (I boot into init level 3,
then go to 5 manually by using 'startx'), then the configured fonts
work in the later instantiation.

Just do a '/etc/init.d/vncserver stop' from a su'ed terminal window on
the direct connected session. A few milliseconds after you see the
'OK' in the terminal window, the fonts at the top of the terminal
window will change to the configured fonts.

If I set up vncserver on a separate user (user2), then both sesions
are truely independent and each has their own font lock.  However, I
would rather have both the vncserver session and the direct startx
session have the same files and the same user directory.

Version-Release number of selected component (if applicable):

[user2@hoho2 user2]$ rpm -q vnc
vnc-4.0-3
[user2@hoho2 user2]$

How reproducible:

  Always - for months (I thought it was a bug and submitted bug reports)

Steps to Reproduce:

The problem or lock conflict can be seen by:

0. Configure vncserver to start up as 'user1' at boot time. Configure
/home/user1/.vnc/xstartup so that it opens the desktop.

Configure the fonts displayed in the fedora menu to something
noticably diferent from the default fonts (e.g., bigger - bolder).
(This can be done after booting once)

1. Boot again to init level 3
2. log in as the same user ('user1') on the command line login 
4. execute 'startx'  (configured to go to desktop)
5. inspect the fonts in the fedora menu - will be default fonts
6, Log in remotely to vnc desktop - should have configured fonts.
  
Actual results:

 see above step 5.

Expected results:

  Would be nice to see the configured fonts in both the direct startx
login and the vnc login.

Additional info:
Comment 1 Tim Waugh 2004-07-06 18:06:58 EDT
Not a VNC bug.

*** This bug has been marked as a duplicate of 125256 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.