Bug 1273323 - Don't set NM_CONTROLLED=no for devices used for root on iSCSI
Don't set NM_CONTROLLED=no for devices used for root on iSCSI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
:
Depends On:
Blocks: 1387678
  Show dependency treegraph
 
Reported: 2015-10-20 04:34 EDT by Radek Vykydal
Modified: 2016-11-03 19:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.60-1
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
: 1387678 (view as bug list)
Environment:
Last Closed: 2016-11-03 19:18:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Vykydal 2015-10-20 04:34:22 EDT
This paragraph from RHEL 7 Installation Guide

"If / is placed on an iSCSI target, Anaconda sets NetworkManager to ignore any network interfaces that were active during the installation process. These interfaces will also be configured by initrd when the system starts. If NetworkManager were to reconfigure these interfaces, the system would lose its connection to /."

is no longer true. NM should handle connection established in initramfs just fine.
Port
https://github.com/rhinstaller/anaconda/commit/9af79b2fca8783face495f88c6c4b13001f6c9f1
from master (+ remove no longer used import).
Comment 2 Michal Kovarik 2016-07-27 06:43:13 EDT
Verified on RHEL-7.3-20160719.1 with anaconda-21.48.22.80-1. NM_CONTROLLED is not set in ifcfg script, when root is on iscsi device.
Comment 4 errata-xmlrpc 2016-11-03 19:18:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.