Bug 1273355 - Java can not print when Masquerade enabled
Java can not print when Masquerade enabled
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
22
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 05:24 EDT by hardillb@gmail.com
Modified: 2016-02-22 05:00 EST (History)
3 users (show)

See Also:
Fixed In Version: firewalld-0.4.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-21 11:30:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Java class to list printers (834 bytes, text/plain)
2015-10-20 05:24 EDT, hardillb@gmail.com
no flags Details

  None (edit)
Description hardillb@gmail.com 2015-10-20 05:24:02 EDT
Created attachment 1084667 [details]
Java class to list printers

Description of problem:
Java can not print when Masquerade is enabled

Version-Release number of selected component (if applicable):
firewalld-0.3.14.2-4.fc22


How reproducible:

Compile the attached Test.java


Steps to Reproduce:
1. Launch the Firewall Configuration tool
2. Check the Masquerade box
3. Run java Test

Actual results:
$ java Test 
Default PrintService: null
no PrintService found


Expected results:

$ java Test 
Default PrintService: IPP Printer : CUPSPDFPrinter
number of Services 6
printer name 1 CUPSPDFPrinter
accepting accepting-jobs
printer name 2 gbhurlaa
accepting accepting-jobs
printer name 3 gbhurlaa.confidential
accepting accepting-jobs
printer name 4 gbhurlh3
accepting accepting-jobs
printer name 5 gbhurlh3.confidential
accepting accepting-jobs
printer name 6 PostScript
accepting accepting-jobs

Additional info:

From looking at the cups ouput you can see that incoming connections that should be coming from localhost are coming in from the external ip address. When masquerading is disabled these connections come from 127.0.0.1

The masquerade rule added to iptables should exclude traffic to localhost
Comment 1 Georg Müller 2015-12-07 08:47:18 EST
I had a similar issue with rabbitmq-server, which does not start due to masquerading issues.

I reported a bug upstream in firewalld:
https://github.com/t-woerner/firewalld/issues/61
Comment 2 Fedora Update System 2016-02-04 10:41:36 EST
firewalld-0.4.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fc0691e6a7
Comment 3 Fedora Update System 2016-02-04 20:23:50 EST
firewalld-0.4.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fc0691e6a7
Comment 4 Fedora Update System 2016-02-08 08:29:24 EST
firewalld-0.4.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fc0691e6a7
Comment 5 Fedora Update System 2016-02-09 17:27:59 EST
firewalld-0.4.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fc0691e6a7
Comment 6 Fedora Update System 2016-02-21 11:30:29 EST
firewalld-0.4.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 hardillb@gmail.com 2016-02-21 12:12:57 EST
Any chance of getting this built for F22 as well (where it was orginally reported)?
Comment 8 Jiri Popelka 2016-02-22 05:00:22 EST
I don't think so, 0.4.0 has a lot changes.
But the package itself is 'noarch' so you should be good to go with the F23 one.

Note You need to log in before you can comment on or make changes to this bug.