Bug 1273359 - [ru_RU, zh_TW][firstboot] Translations incomplete.
[ru_RU, zh_TW][firstboot] Translations incomplete.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firstboot (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Kolman
Engineering Localization bugs mailing list
: Translation
Depends On:
Blocks: 1262678 1313485 1340415
  Show dependency treegraph
 
Reported: 2015-10-20 05:29 EDT by Bhushan Barve
Modified: 2016-11-03 19:04 EDT (History)
7 users (show)

See Also:
Fixed In Version: firstboot-19.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:04:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FAIL category definition document (15.53 KB, application/vnd.oasis.opendocument.graphics)
2015-10-20 05:29 EDT, Bhushan Barve
no flags Details

  None (edit)
Description Bhushan Barve 2015-10-20 05:29:30 EDT
Created attachment 1084670 [details]
FAIL category definition document

Description of problem: As reported by the translators in the l10n qa event, translations for this package falls under FAIL-4 and FAIL-5  Categories.


Version-Release number of selected component (if applicable):
firstboot-19.9-10.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.NA
2.
3.

Actual results:
Translations are not completed.

Expected results:
Translation should be completed 100% and be pulled and build in the package in order to reflect the translation work done in UI/CLI.

Additional info:
FAIL Categories are defined by l10n team lead, and the file is attached with this bug.
Comment 2 Noriko Mizumoto 2016-01-14 22:58:14 EST
Could you please provide the translation stats?
Comment 3 Krishna Babu K 2016-01-15 06:30:35 EST
branch: * rhel-7.3
Name: firstboot
Version: 19.9
Release: 10%{?dist}
 
./firstboot.pot: 0 translated messages, 24 untranslated messages.
 
Translated LANGs:
./de.po: 24 translated messages.
./es.po: 24 translated messages.
./fr.po: 24 translated messages.
./it.po: 24 translated messages.
./ja.po: 24 translated messages.
./ko.po: 24 translated messages.
./pt_BR.po: 24 translated messages.
./ru.po: 24 translated messages.
./zh_CN.po: 24 translated messages.
./zh_TW.po: 24 translated messages.
 
Fuzzy LANGs:
 
Untranslated LANGs:
Comment 4 Noriko Mizumoto 2016-01-18 20:11:55 EST
Krishna,
Could you please refer to the comment #15 of the bug #1221520 by Milan, and regenerate with intltool-update?
Comment 5 sandeep shedmake 2016-01-21 04:22:24 EST
(In reply to Krishna Babu K from comment #3)
> branch: * rhel-7.3
> Name: firstboot
> Version: 19.9
> Release: 10%{?dist}
>  

Correction: used 'make update-po' inside 'po' sub directory and regenerated PO statistics.


./firstboot-19.9/po/firstboot.pot: 0 translated messages, 19 untranslated messages.


./firstboot-19.9/po/de.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/es.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/fr.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/it.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/ja.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/ko.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/pt_BR.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/ru.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/zh_CN.po: 18 translated messages, 1 untranslated message.
./firstboot-19.9/po/zh_TW.po: 18 translated messages, 1 untranslated message.
Comment 6 Noriko Mizumoto 2016-01-21 10:08:17 EST
[RHEL 7.3] Assigned Jens for rhel7.3 localization preparation.
Comment 7 Noriko Mizumoto 2016-01-21 10:15:08 EST
Sorry this package can be found on fedora.zanta.org, removed Jens.

Martin,
It seems 100% localized on fedora.zanata.org, while the stat indicates some untranslated messages resulting l10n QA test failed. Could you please update zanata?
https://fedora.zanata.org/iteration/view/firstboot/master

Thanks
Comment 8 Martin Kolman 2016-02-09 09:50:52 EST
The Firstboot translations have been updated from fedora.zanata.org.
Comment 12 Noriko Mizumoto 2016-02-24 18:54:57 EST
Got it thanks!
Comment 13 Noriko Mizumoto 2016-04-12 01:08:23 EDT
Hi maintainer

We have completed 8 out of 10 supported languages translation 100% for your package (de, es, fr, ja, pt-br, ru, zh-cn and zh-tw). I am planning to have second translation period in early to mid June to catch up rest 2 languages (ko and it), but can't 100% guarantee as we are in recruiting phase. So I assign this bug back to you. Please go ahead and move to next.
Comment 14 Martin Kolman 2016-04-12 05:11:40 EDT
(In reply to Noriko Mizumoto from comment #13)
> Hi maintainer
> 
> We have completed 8 out of 10 supported languages translation 100% for your
> package (de, es, fr, ja, pt-br, ru, zh-cn and zh-tw). I am planning to have
> second translation period in early to mid June to catch up rest 2 languages
> (ko and it), but can't 100% guarantee as we are in recruiting phase. So I
> assign this bug back to you. Please go ahead and move to next.


Thanks! :)

OK, I'll do a new build for now so that those 8 languages are up to date. Let me know if the 2 remaining languages are translated and I can do another build then (as long as it happens during the devel phase).
Comment 15 Noriko Mizumoto 2016-06-16 21:23:40 EDT
Hi Martin

Now all ten languages have been 100% completed, and ready to build, thank you for waiting! If any further update is required later, please do let me know otherwise I won't come back and check the status of this package.

Thanks

noriko
Comment 16 Martin Kolman 2016-06-17 07:43:13 EDT
(In reply to Noriko Mizumoto from comment #15)
> Hi Martin
> 
> Now all ten languages have been 100% completed, and ready to build, thank
> you for waiting! If any further update is required later, please do let me
> know otherwise I won't come back and check the status of this package.
> 
> Thanks
> 
> noriko

Thanks! I pulled in the updated translations and did a new build.
Comment 20 errata-xmlrpc 2016-11-03 19:04:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2155.html

Note You need to log in before you can comment on or make changes to this bug.