Bug 1273372 - Data Tiering:getting failed to fsync on germany-hot-dht (Structure needs cleaning) warning
Data Tiering:getting failed to fsync on germany-hot-dht (Structure needs clea...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
:
Depends On: 1272036 1274595
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-10-20 06:22 EDT by Nithya Balachandran
Modified: 2016-06-16 09:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272036
Environment:
Last Closed: 2016-06-16 09:40:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-10-20 06:22:10 EDT
+++ This bug was initially created as a clone of Bug #1272036 +++

Description of problem:
======================

I am seeing getting this error when there is a failure to migrate file to hot tier


In my case following is the way I probably hit it.

I had the following setup:

a hot tier 2x2 setup with each 1GB bricks
over a cold tier 2x2 of 500GB space

I then created files f1 of 700MB and then after f1 got demoted i created f2 of 700MB. When even f2 got demoted, I touched both files to get them promoted to hot brick, and see what happens as it can accomodate only 1GB data.

I then saw  logs and found this error.





Version-Release number of selected component (if applicable):
==============================================================
glusterfs-server-3.7.5-0.18.gitb8ba012.el7.centos.x86_64




[2015-10-14 12:12:04.867032] W [dht-rebalance.c:1247:dht_migrate_file] 0-germany-tier-dht: /berlin.7: failed to fsync on germany-hot-dht (Structure needs cleaning)
[2015-10-14 13:14:08.219263] W [dht-rebalance.c:1247:dht_migrate_file] 0-greece-tier-dht: /athens.10: failed to fsync on greece-hot-dht (Structure needs cleaning)
[2015-10-14 13:28:25.074476] W [dht-rebalance.c:1247:dht_migrate_file] 0-greece-tier-dht: /athens.2: failed to fsync on greece-hot-dht (Structure needs cleaning)
[2015-10-14 13:30:26.091045] W [dht-rebalance.c:1247:dht_migrate_file] 0-greece-tier-dht: /athens.10: failed to fsync on greece-hot-dht (Structure needs cleaning)
[2015-10-14 13:34:26.703553] W [dht-rebalance.c:1247:dht_migrate_file] 0-greece-tier-dht: /athens.2: failed to fsync on greece-hot-dht (Structure needs cleaning)
[2015-10-14 13:34:51.579771] W [dht-rebalance.c:1247:dht_migrate_file] 0-greece-tier-dht: /athens.3: failed to fsync on greece-hot-dht (Structure needs cleaning)
[2015-10-14 13:38:26.134830] W [dht-rebalance.c:1247:dht_migrate_file] 0-greece-tier-dht: /athens.4: failed to fsync on greece-hot-dht (Structure needs cleaning)
[2015-10-14 13:44:24.459860] W [dht-rebalance.c:1247:dht_migrate_file] 0-greece-tier-dht: /athens.3: failed to fsync on greece-hot-dht (Structure needs cleaning)



attaching sos report:
Kindly refer to "greece" volume tier logs

--- Additional comment from nchilaka on 2015-10-15 06:43:00 EDT ---

sosreprots

rhsqe-repo.lab.eng.blr.redhat.com:/home/repo/sosreports/bug.1272036
[root@rhsqe-repo sosreports]#
Comment 1 Vijay Bellur 2015-10-20 06:25:19 EDT
REVIEW: http://review.gluster.org/12401 (cluster/dht : op_ret not set correctly in dht_fsync_cbk) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2015-10-21 06:02:26 EDT
COMMIT: http://review.gluster.org/12401 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 9710f58e5874bccb4b328abef80ea226ccf9c798
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Oct 20 15:53:15 2015 +0530

    cluster/dht : op_ret not set correctly in dht_fsync_cbk
    
    local->op_ret was not set correctly in dht_fsync_cbk in case
    of files being migrated
    
    Change-Id: If73ae04368ea0c7f6868c8704dfc2deb2faee753
    BUG: 1273372
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12401
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:40:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.