Bug 1273390 - upgrade progress is not shown in Fedora 21
upgrade progress is not shown in Fedora 21
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 06:59 EDT by Kamil Páral
Modified: 2015-11-02 17:05 EST (History)
4 users (show)

See Also:
Fixed In Version: dnf-plugin-system-upgrade-0.5.0-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 16:49:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no progress shown in graphics (11.00 KB, image/png)
2015-10-20 07:00 EDT, Kamil Páral
no flags Details
no progress shown in text (29.03 KB, image/png)
2015-10-20 07:00 EDT, Kamil Páral
no flags Details
workstation upgrade log (1004.94 KB, text/plain)
2015-10-20 07:00 EDT, Kamil Páral
no flags Details
server upgrade log (871.08 KB, text/plain)
2015-10-20 07:01 EDT, Kamil Páral
no flags Details
minimal upgrade log (567.43 KB, text/plain)
2015-10-20 07:01 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2015-10-20 06:59:37 EDT
Description of problem:
I tried to upgrade Fedora 21 to Fedora 23 using system-upgrade. The screen says "Starting system upgrade. This will take a while" in both graphical and text mode, and this message is never updated. The upgrade is happening in the background, but the PC seems stuck/not doing anything. If you wait a few tens of minutes, the upgrade is finished and PC reboots correctly into F23.


There's one more issue, which is most probably unrelated and a different bug, and that's this traceback at the end of the upgrade (occurs only sometimes):
Oct 20 12:49:13 localhost.localdomain dnf[497]: Traceback (most recent call last):
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/bin/dnf", line 36, in <module>
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
Oct 20 12:49:13 localhost.localdomain dnf[497]: return 0
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
Oct 20 12:49:13 localhost.localdomain dnf[497]: return _main(base, args)
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 145, in _main
Oct 20 12:49:13 localhost.localdomain dnf[497]: except dnf.exceptions.DepsolveError as e:
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 273, in run_transaction
Oct 20 12:49:13 localhost.localdomain dnf[497]: self._call_sub("transaction")
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 278, in _call_sub
Oct 20 12:49:13 localhost.localdomain dnf[497]: subfunc(*args)
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 427, in transaction_upgrade
Oct 20 12:49:13 localhost.localdomain dnf[497]: reboot()
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 59, in reboot
Oct 20 12:49:13 localhost.localdomain dnf[497]: check_call(["systemctl", "reboot"])
Oct 20 12:49:13 localhost.localdomain dnf[497]: File "/usr/lib64/python2.7/subprocess.py", line 540, in check_call
Oct 20 12:49:13 localhost.localdomain dnf[497]: raise CalledProcessError(retcode, cmd)
Oct 20 12:49:13 localhost.localdomain dnf[497]: subprocess.CalledProcessError: Command '['systemctl', 'reboot']' returned non-zero exit status -15
Oct 20 12:49:13 localhost.localdomain systemd[1]: dnf-system-upgrade.service: Main process exited, code=exited, status=1/FAILURE
Oct 20 12:49:13 localhost.localdomain systemd[1]: Stopped System Upgrade.
Oct 20 12:49:13 localhost.localdomain systemd[1]: dnf-system-upgrade.service: Unit entered failed state.
Oct 20 12:49:13 localhost.localdomain systemd[1]: dnf-system-upgrade.service: Failed with result 'exit-code'.
Oct 20 12:49:13 localhost.localdomain systemd[1]: Rebooting as result of failure.

But even when this traceback is not shown, there's always this:
Oct 20 12:23:28 localhost.localdomain systemd[1]: dnf-system-upgrade.service: Main process exited, code=exited, status=1/FAILURE
Oct 20 12:23:28 localhost.localdomain systemd[1]: Stopped System Upgrade.
Oct 20 12:23:28 localhost.localdomain systemd[1]: dnf-system-upgrade.service: Unit entered failed state.
Oct 20 12:23:28 localhost.localdomain systemd[1]: dnf-system-upgrade.service: Failed with result 'exit-code'.
Oct 20 12:23:28 localhost.localdomain systemd[1]: Rebooting as result of failure.

Not sure how harmless this is.


Version-Release number of selected component (if applicable):
I used this version:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-15941
dnf-plugin-system-upgrade-0.4.1-1.fc21
with this libsolv update:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-b3a8c0e68d
libsolv-0.6.14-2.fc21
hawkey-0.5.3-3.fc21
(but later, I tested even stable F21 libsolv+hawkey and it behaves the same).
and fully updated F21 from stable repos

How reproducible:
always, three different people reproduced this

Steps to Reproduce:
1. fully update F21
2. run sudo dnf system-upgrade download --releasever=23 --distro-sync
3. run sudo dnf system-upgrade reboot
4. see progress not shown during upgrade
Comment 1 Kamil Páral 2015-10-20 07:00 EDT
Created attachment 1084680 [details]
no progress shown in graphics
Comment 2 Kamil Páral 2015-10-20 07:00 EDT
Created attachment 1084681 [details]
no progress shown in text
Comment 3 Kamil Páral 2015-10-20 07:00 EDT
Created attachment 1084682 [details]
workstation upgrade log
Comment 4 Kamil Páral 2015-10-20 07:01 EDT
Created attachment 1084683 [details]
server upgrade log
Comment 5 Kamil Páral 2015-10-20 07:01 EDT
Created attachment 1084684 [details]
minimal upgrade log
Comment 6 Kamil Páral 2015-10-20 07:38:43 EDT
It seems our criteria cover only FN->FN+1 upgrade, but not FN-1->FN+1:
"For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed. "
https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Upgrade_requirements

It seems to me they should, or our tools should not allow version skipping, but that's probably discussion for another time. But I think we should take into account that currently system-upgrade is almost completely broken (from user POV) for F21. Hardly anyone will wait 30+ minutes staring at "Starting system upgrade" message, without reading common bugs. It seems to me that we either need this fixed, or pull system-upgrade from F21 and continue using fedup.

Please note that system-upgrade for F21 has been in updates-testing for more than a month, and apparently I was the first one to test it (or post feedback), today:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-15941

Also, I asked dnf folks to push a libsolv fix for F21, which should fix bug 1260989:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-b3a8c0e68d
However, this fix is quite risky from their POV, because the delta is quite large. To top it off, I didn't manage to reproduce bug 1260989 and I don't know why, so I'm not even sure it's needed and whether it's better to have it or not. A lot of uncertainty.

We can still easily unpush system-upgrade from F21, fedup will not get obsoleted, libsolv fixes will not be needed, and people can use well-tested fedup for F21->F22 upgrade, and then use system-upgrade to go F22->F23. I tested F21->F22 upgrade using fedup and it works fine.

I'm not sure a blocker discussion is the best channel to discuss this (since it might not fail our criteria), but since we don't have any other means to track things, marking as such.
Comment 7 Will Woods 2015-10-20 11:13:30 EDT
This should be fixed in dnf-plugin-system-upgrade 0.5.x (which is for F21 only), which a) switches the boot splash to text mode and b) dumps the DNF output to the console.

See these two commits on f21-branch:

  https://github.com/rpm-software-management/dnf-plugin-system-upgrade/commit/e07cf7813c0cd623babb1b99ab044f8c075931b0
  https://github.com/rpm-software-management/dnf-plugin-system-upgrade/commit/edbf7fe144fc953a3f67e4ca795e71582fd3803c

A build of 0.5.x will come shortly after 0.7.x (which is the next F22+ version).
Comment 8 Kamil Páral 2015-10-21 04:44:58 EDT
Will, can you please make sure the new builds require latest dnf/hawkey/libsolv, as listed in bug 1260989? Because without those updates, system-upgrade will simply not work and fail with cryptic messages. Thanks!
Comment 9 Adam Williamson 2015-10-22 12:30:16 EDT
Discussed at 2015-10-22 Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2015-10-22/f23-final-go_no_go-meeting.2015-10-22-16.00.log.txt . Rejected as a blocker: the criteria omission of upgrades from two releases before the one being tested is intentional, i.e., we specifically mean *not* to block on such upgrades. This may be revisited for future releases, but not for F23.

(As the fix for this will be an update to F21, though, it will still get done, and probably before F23 release).
Comment 10 Fedora Update System 2015-10-28 12:11:40 EDT
dnf-plugin-system-upgrade-0.5.0-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7627ff59ca
Comment 11 Fedora Update System 2015-11-01 21:55:06 EST
dnf-plugin-system-upgrade-0.5.0-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf-plugin-system-upgrade'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7627ff59ca
Comment 12 Kamil Páral 2015-11-02 11:26:43 EST
This is on its way to stable updates, so we probably don't need to document this on CommonBugs page (will be closed in a day).
Comment 13 Fedora Update System 2015-11-02 16:49:23 EST
dnf-plugin-system-upgrade-0.5.0-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.