Bug 127340 - ifup-wireless cannot set multiple wep keys
Summary: ifup-wireless cannot set multiple wep keys
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-06 19:47 UTC by Andreas Piesk
Modified: 2014-03-17 02:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 20:50:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to support up to 4 keys (738 bytes, patch)
2004-07-06 19:49 UTC, Andreas Piesk
no flags Details | Diff

Description Andreas Piesk 2004-07-06 19:47:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
iwconfig can set up to 4 different key for every wlan adapter but
ifup-wireless doesn't support more than one key. this little patch
solved my problem:

--- initscripts-7.31.13.EL/sysconfig/network-scripts/ifup-wireless
2002-06-27 19:04:48.000000000 +0200
+++
initscripts-7.31.13.EL/sysconfig/network-scripts/ifup-wireless.mod
2004-07-06 21:33:20.000000000 +0200
@@ -53,8 +53,12 @@
 if [ -n "$RATE" ] ; then
     iwconfig $DEVICE rate $RATE
 fi
-if [ -n "$KEY" ] ; then
-    iwconfig $DEVICE key $KEY
+if [ -n "$KEY1" -o -n "$KEY2" -o -n "$KEY3" -o -n "$KEY4" ] ; then
+    [ -n "$KEY1" ] && iwconfig $DEVICE key [1] $KEY1
+    [ -n "$KEY2" ] && iwconfig $DEVICE key [2] $KEY2
+    [ -n "$KEY3" ] && iwconfig $DEVICE key [3] $KEY3
+    [ -n "$KEY4" ] && iwconfig $DEVICE key [4] $KEY4
+    [ -n "$DEFAULTKEY" ] && iwconfig $DEVICE key [${DEFAULTKEY}]
 else
     iwconfig $DEVICE key off
 fi

the key file looks like that:

DEFAULTKEY=2
KEY1=bla
KEY2=foo
KEY3=bar


Version-Release number of selected component (if applicable):
7.31.13.EL

How reproducible:
Always

Steps to Reproduce:
1. n/a
2.
3.
    

Additional info:

Comment 1 Andreas Piesk 2004-07-06 19:49:06 UTC
Created attachment 101664 [details]
patch to support up to 4 keys

Comment 2 Suzanne Hillman 2004-07-15 17:41:07 UTC
Internal RFE bug #127957 entered.

Comment 3 Bill Nottingham 2005-09-20 20:50:24 UTC
This problem is resolved in the next release of Red Hat Enterprise Linux (RHEL
4). Red Hat does not currently plan to provide a resolution for this in a Red
Hat Enterprise Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects. 




Note You need to log in before you can comment on or make changes to this bug.