Bug 127343 - PHP manual (ref.var.html) causes 500 error
Summary: PHP manual (ref.var.html) causes 500 error
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-06 20:17 UTC by Steve Fox
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-06 20:36:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ref.var.html (8.60 KB, text/html)
2004-07-06 20:20 UTC, Steve Fox
no flags Details

Description Steve Fox 2004-07-06 20:17:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.15

Description of problem:
I have the PHP manual (multiple files) downloaded from
http://www.php.net/get/php_manual_en.tar.gz/from/a/mirror and am
trying to view chapter CXIV "Variable Functions". Trying to view this
document through http://localhost throws a 500 error and the apache
log shows:

[Tue Jul 06 14:44:16 2004] [error] [client 127.0.0.1] Syntax error in
type map, no ':' in /home/drfickle/public_html/docs/PHP/ref.var.html
for header <!doctype html public "-//w3c//dtd html 4.01
transitional//en">\n

Version-Release number of selected component (if applicable):
httpd-2.0.49-4

How reproducible:
Always

Steps to Reproduce:
1.Download the PHP manual and extract it.
2. Load http://localhost/PHP/ref.var.html in my browser
3. 500 error shown
    

Additional info:

I get this same error with Mozilla and elinks. I can use these
browsers to read the file properly off the file system, avoiding
Apache. As far as I can tell, no other pages in the manual have this
problem.

I am using an ext3 filesystem and have this same problem on another
machine with the same configuration. A co-worker using Apache 2.0.49
on Debian was unable to recreate it. I have mod_perl, mod_ssl, and PHP
installed.

Comment 1 Steve Fox 2004-07-06 20:20:07 UTC
Created attachment 101665 [details]
ref.var.html

Here is the file that makes Apache upset. It can even be copied to an empty
directory and give the same error.

Comment 2 Joe Orton 2004-07-06 20:36:36 UTC
The .var. extension means the page is being interpreted as a type-map
file by default.

Either uncomment the "AddHandler type-map .var" from httpd.conf, or,
if you are allowing FileInfo overrides in /home/*., just add an
.htaccess file into the PHP manual directory, with the single line:

   RemoveHandler .var


Comment 3 Steve Fox 2004-07-06 21:31:32 UTC
Wow, that is wild. It never caused a problem on FC1, so I guess I
mustn't have had the handler enabled. Thanks for the quick, very
helpful response.


Note You need to log in before you can comment on or make changes to this bug.