Bug 1273437 - In Host Edit Form, overriding a 'long key name smart variable' doesn't truncates the key name.
Summary: In Host Edit Form, overriding a 'long key name smart variable' doesn't trunca...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1278718
TreeView+ depends on / blocked
 
Reported: 2015-10-20 12:49 UTC by Jitendra Yejare
Modified: 2019-09-25 20:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:58:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot Attached. (152.84 KB, image/png)
2015-10-20 12:49 UTC, Jitendra Yejare
no flags Details
[Verified] Screenshot Attached (131.70 KB, image/png)
2016-04-04 11:05 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 12224 None None None 2016-04-22 16:28:42 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jitendra Yejare 2015-10-20 12:49:54 UTC
Created attachment 1084726 [details]
Screenshot Attached.

Description of problem:
In Host Edit Form, overriding a 'long key name smart variable' doesn't truncates the key name.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201510151605git8893c3b.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. In Puppet class, Create a smart variable with a long key name.
2. Add above puppet class to any host.
3. In Host, under parameters tab override the smart variable value and observe the smart variable name appears under the section 'Puppet class overrides'.
4. Hover on that name.

Actual results:
The smart variable name is not truncated and not showing the full name of smart variable.

Expected results:
The smart variable name should be truncated and should display the full name.

Additional info:

Comment 2 Tomer Brisker 2015-10-28 09:23:54 UTC
Connecting redmine issue http://projects.theforeman.org/issues/12224 from this bug

Comment 3 Bryan Kearney 2015-10-29 19:01:50 UTC
Upstream has rejected since they can not reproduce. Adding to 6.2 to retest.

Comment 8 Jitendra Yejare 2016-04-04 11:05:41 UTC
Created attachment 1143306 [details]
[Verified] Screenshot Attached

Comment 9 Jitendra Yejare 2016-04-04 11:05:54 UTC
Verified this issue on Sat 6.2 snap 6.1

The issue is no more reproducible. I see the name of long name smart variable on hover while overriding from host.

Verification screenshot attached.

So moving the status to Verified.

Comment 12 errata-xmlrpc 2016-07-27 08:58:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.