Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1273447 - After a command is finished tasks are not cleared and stay in executing status
Summary: After a command is finished tasks are not cleared and stay in executing status
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.0.0-alpha
: 4.0.0
Assignee: Ravi Nori
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-20 13:04 UTC by Fred Rolland
Modified: 2016-07-05 07:49 UTC (History)
10 users (show)

Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
--no tech note required
Clone Of:
Environment:
Last Closed: 2016-07-05 07:49:18 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
Screenshot (192.42 KB, image/png)
2015-10-20 13:10 UTC, Fred Rolland
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 47526 0 master MERGED engine : After an command is finished tasks are not cleared and stay in executing status Never
oVirt gerrit 50987 0 ovirt-engine-3.6 MERGED engine : After an command is finished tasks are not cleared and stay in executing status 2015-12-24 09:15:07 UTC
oVirt gerrit 50991 0 ovirt-engine-3.6.2 MERGED engine : After an command is finished tasks are not cleared and stay in executing status 2015-12-27 13:59:00 UTC

Description Fred Rolland 2015-10-20 13:04:15 UTC
Description of problem:
In the 'Tasks' tab, some of the actions are not finishing.
For example : 
- Add disk
- Remove disk
- Hibernate VM

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a disk
2. Wait until it is created


Actual results:
See in the "Tasks" tab that the action is still executing and is never ending.

Expected results:
The task should finish.

Additional info:

Comment 1 Fred Rolland 2015-10-20 13:10:55 UTC
Created attachment 1084751 [details]
Screenshot

Comment 2 Tal Nisan 2015-10-20 13:15:33 UTC
Discussed with Ravi about this issue to find the root cause, the change has only been introduced to master, moving to 4.0.0

Comment 3 Lukas Svaty 2016-06-24 10:41:55 UTC
verified in ovirt-engine-4.0.0.4-0.1.el7ev.noarch

Comment 4 Sandro Bonazzola 2016-07-05 07:49:18 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.