Bug 127347 - fsck on root fs exiting with 2 breaks system startup
Summary: fsck on root fs exiting with 2 breaks system startup
Status: CLOSED DUPLICATE of bug 117641
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-06 21:18 UTC by Krzysztof Halasa
Modified: 2014-03-17 02:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Krzysztof Halasa 2004-07-06 21:18:44 UTC
Description of problem:
/etc/rc.d/rc.sysinit treats fsck on root filesystem exiting with
code 2 as error and stops automatic system startup with sulogin.

Version-Release number of selected component (if applicable):
7.53-1 and probably earlier versions

How reproducible:
While system is booting when root filesystem needs fsck and then
reboot is required for the kernel to update in-memory filesystem
data.

Steps to Reproduce:
1. Not trivial: umount /
2. Damage root fs data in a way which will cause fsck to return code 2
3. reboot system
  
Actual results:
/etc/rc.d/rc.sysinit prints:
   *** An error occurred during the file system check.
   *** Dropping you to a shell; the system will reboot
   *** when you leave the shell.
and runs sulogin.

Expected results:
System is rebooted automatically, probably after a short pause
allowing watching admin to react somehow. After reboot root
filesystem would be clean and fsck would not be run on it.

Comment 1 Bill Nottingham 2004-07-06 21:32:28 UTC

*** This bug has been marked as a duplicate of 117641 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:20 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.