Bug 1273486 - [SR-IOV] - Block Hotplug/unplug 'pci-passthrough' vNIC types on 3.6
[SR-IOV] - Block Hotplug/unplug 'pci-passthrough' vNIC types on 3.6
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity high (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Alona Kaplan
Michael Burman
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 10:29 EDT by Michael Burman
Modified: 2016-02-10 14:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:19:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: Triaged+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48439 master MERGED engine: Block Hotplug/unplug 'pci-passthrough' vNIC types Never
oVirt gerrit 48595 ovirt-engine-3.6 MERGED engine: Block Hotplug/unplug 'pci-passthrough' vNIC types Never

  None (edit)
Description Michael Burman 2015-10-20 10:29:32 EDT
Description of problem:
[SR-IOV] - Block Hotplug/unplug 'pci-passthrough' vNIC types on 3.6.

Since this BZ 1234328 will be done only for 4.0, Hotplug/unplug 'pci-passthrough' vNICs type must be blocked on 3.6.
This is causing a lot of issues as it not blocked on 3.6.
If user by mistake Hotplug/unplug 'pci-passthrough' vNIC type while the VM is running, it will cause several issues. 
Some of VFs could be considered as non-free VFs on host, while they actually free and to some more issues related to sr-iov.
Comment 1 Yaniv Lavi (Dary) 2015-10-29 08:47:46 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 2 Michael Burman 2015-11-29 06:26:48 EST
Verified on - 3.6.1-0.2.el6 

Note that in this point we have 2 different validations:

1) Is the network attached to host? 
Although it's not relevant for 'passthrough' networks, this validation taking place because the Hotplug/unplug passthrough vNICs is not supported on 3.6
 
"Error while executing action: 

sr-vm1:
The Network does not exist on the host the VM is running on.
Either add the Network to the Host or migrate the VM to a Host that has this Network."

- For DEV + QA --> this validation should be skipped on 4.0/when Hotplug/unplug will be supported, cause it's not relevant to 'passthorugh' networks.
We shouldn't see such error messages ^^ for 'passthrough' networks.

2) If the network attached to host, is it a 'passthrough' one? if yes, then Hotplug/unplug is not supported on 3.6 -->

"Error while executing action: 

sr-vm1:
Cannot add Interface. Hot plugging/unplugging of passthrough virtual machine network interface is not supported."

This was discussed and agreed with DEV, no matter if the 'passthrough' network is attached or not to host, user/admin won't be able to Hotplug/unplug 'pci-passthrough' vNICs to running VM/s and that is the desired behavior for 3.6
Comment 3 Sandro Bonazzola 2015-12-16 07:19:46 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.