Bug 127352 - xsltproc core dumps on simple inputs
Summary: xsltproc core dumps on simple inputs
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libxslt   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-06 23:39 UTC by Eric Raymond
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-08 12:46:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simple test case which has been known to trigger a cire dump (1.12 KB, text/plain)
2004-07-06 23:40 UTC, Eric Raymond
no flags Details

Description Eric Raymond 2004-07-06 23:39:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
xsltproc segfaults on a simple input, apparently due to a double
free().  The bug is not always reproducible and may be dependent
on free RAM being below some threshold.

Version-Release number of selected component (if applicable):
libxslt-1.1.5-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Run 

xsltproc --nonet --xinclude
http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
 coredump.xml

using the enclosed coredump.xml file.

2. Pray that the phase of the moon is correct.

    

Actual Results:  A core dump.  Sometimes.   Changing the XML input did
not seem to
affect whether it happened or not -- it does not seem to be dependent 
on input length.

Expected Results:  Completion with status zero.


Additional info:

Comment 1 Eric Raymond 2004-07-06 23:40:45 UTC
Created attachment 101671 [details]
Simple test case which has been known to trigger a cire dump

Comment 2 Daniel Veillard 2004-07-08 12:46:13 UTC
 Fixed upstream and should be in rawhide:

paphio:~ -> /usr/bin/xsltproc --nonet --xinclude
http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
coredump.xml
Writing g3cat.1 for refentry(foobarman)
paphio:~ -> rpm -qf /usr/bin/xsltproc
libxslt-1.1.8-1
paphio:~ ->

  In general it's better to use the dedicated bug reporting facilities
see http://xmlsoft.org/XSLT/bugs.html , as xsltproc --help suggests

  thanks,

Daniel


Comment 3 Joe Orton 2004-10-16 22:08:47 UTC
Any chance we could see an FC2 update issued to fix this, Daniel? I
keep hitting this too.


Note You need to log in before you can comment on or make changes to this bug.