Bug 1273524 - Hosted engine problems
Hosted engine problems
Status: CLOSED DUPLICATE of bug 1269768
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Ilanit Stein
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 11:40 EDT by matt.deboer
Modified: 2015-10-27 08:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 08:10:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
hosted engine setup log (388.16 KB, text/plain)
2015-10-26 16:39 EDT, matt.deboer
no flags Details

  None (edit)
Description matt.deboer 2015-10-20 11:40:51 EDT
Description of problem:
The hosted engine does not show in the administration console.

Version-Release number of selected component (if applicable):


How reproducible:
Multiple reinstalls have all produced the same result.

Steps to Reproduce:
1. Install hosted engine on gluster
2.
3.

Actual results:
Hosted engine does not show in the administration console.
Also a host that the hosted engine was migrated from still shows that it has a virtual machine even though none are running. I think this is preventing the host from going into maintenance mode.

Expected results:


Additional info:
Comment 1 Yedidyah Bar David 2015-10-21 01:24:53 EDT
Please state exact version of relevant components and attach relevant logs - including engine/vdsm/hosted-engine-setup. Thanks.
Comment 2 Doron Fediuck 2015-10-22 10:41:41 EDT
See comment 1; can you please provide the missing information?
Comment 3 Simone Tiraboschi 2015-10-22 11:18:33 EDT
(In reply to matt.deboer from comment #0)
> Hosted engine does not show in the administration console.

This one is already tracked here: https://bugzilla.redhat.com/show_bug.cgi?id=1269768
You can try to manually import the hosted-engine-storage domain into the engine, than the engine VM should appear there.

> Also a host that the hosted engine was migrated from still shows that it has
> a virtual machine even though none are running. I think this is preventing
> the host from going into maintenance mode.

Is that virtual machine the engine VM or is a real fault?
Comment 4 matt.deboer 2015-10-26 16:39 EDT
Created attachment 1086587 [details]
hosted engine setup log
Comment 5 matt.deboer 2015-10-26 16:42:27 EDT
(In reply to Yedidyah Bar David from comment #1)
> Please state exact version of relevant components and attach relevant logs -
> including engine/vdsm/hosted-engine-setup. Thanks.
glusterfs.x86_64 3.7.5-1.el7
glusterfs-api.x86_64 3.7.5-1.el7
glusterfs-cli.x86_64 3.7.5-1.el7
glusterfs-client-xlators.x86_64 3.7.5-1.el7
glusterfs-fuse.x86_64 3.7.5-1.el7
glusterfs-geo-replication.x86_64 3.7.5-1.el7
glusterfs-libs.x86_64 3.7.5-1.el7
glusterfs-server.x86_64 3.7.5-1.el7
gperftools-libs.x86_64 2.4-7.el7
ioprocess.x86_64 0.15.0-2.el7
ipxe-roms-qemu.noarch 20130517-7.gitc4bce43.el7
libcacard-ev.x86_64 10:2.3.0-29.1.el7
libunwind.x86_64 1.1-5.el7
mom.noarch 0.5.1-2.el7
otopi.noarch 1.4.0-1.el7.centos
ovirt-engine-sdk-python.noarch 3.6.0.3-1.el7.centos
ovirt-host-deploy.noarch 1.4.0-1.el7.centos
ovirt-hosted-engine-ha.noarch 1.3.1-1.el7.centos
ovirt-hosted-engine-setup.noarch 1.3.0-1.el7.centos
ovirt-release36.noarch 001-0.5.beta
ovirt-setup-lib.noarch 1.0.0-1.el7.centos
ovirt-vmconsole.noarch 1.0.0-1.el7.centos
ovirt-vmconsole-host.noarch 1.0.0-1.el7.centos
python-cpopen.x86_64 1.3-4.el7
python-daemon.noarch 1.6-4.el7
python-ioprocess.noarch 0.15.0-2.el7
python-lockfile.noarch 1:0.9.1-4.el7
python-paramiko.noarch 1.15.1-1.el7
python-pthreading.noarch 0.1.3-3.el7
qemu-img-ev.x86_64 10:2.3.0-29.1.el7
qemu-kvm-common-ev.x86_64 10:2.3.0-29.1.el7
qemu-kvm-ev.x86_64 10:2.3.0-29.1.el7
qemu-kvm-tools-ev.x86_64 10:2.3.0-29.1.el7
safelease.x86_64 1.0-5.el7
seabios-bin.noarch 1.7.5-11.el7
seavgabios-bin.noarch 1.7.5-11.el7
userspace-rcu.x86_64 0.7.9-1.el7
vdsm.noarch 4.17.10-0.el7.centos
vdsm-cli.noarch 4.17.10-0.el7.centos
vdsm-gluster.noarch 4.17.10-0.el7.centos
vdsm-infra.noarch 4.17.10-0.el7.centos
vdsm-jsonrpc.noarch 4.17.10-0.el7.centos
vdsm-python.noarch 4.17.10-0.el7.centos
vdsm-xmlrpc.noarch 4.17.10-0.el7.centos
vdsm-yajsonrpc.noarch 4.17.10-0.el7.centos
Comment 6 matt.deboer 2015-10-26 17:54:38 EDT
(In reply to Simone Tiraboschi from comment #3)
> (In reply to matt.deboer from comment #0)
> > Hosted engine does not show in the administration console.
> 
> This one is already tracked here:
> https://bugzilla.redhat.com/show_bug.cgi?id=1269768
> You can try to manually import the hosted-engine-storage domain into the
> engine, than the engine VM should appear there.
> 
> > Also a host that the hosted engine was migrated from still shows that it has
> > a virtual machine even though none are running. I think this is preventing
> > the host from going into maintenance mode.
> 
> Is that virtual machine the engine VM or is a real fault?

importing the hosted-engine-storage domain into the engine then a restart of ovirt-engine got it listed as a VM.

This also fixed the "extra" vm showing in the list.
Comment 7 Sandro Bonazzola 2015-10-27 08:10:41 EDT
Closing as duplicate of bug #1269768

*** This bug has been marked as a duplicate of bug 1269768 ***

Note You need to log in before you can comment on or make changes to this bug.