Bug 1273539 - Remove dependency of glusterfs on rsyslog
Remove dependency of glusterfs on rsyslog
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: Milind Changire
Rahul Hinduja
: ZStream
Depends On:
Blocks: 1299184
  Show dependency treegraph
 
Reported: 2015-10-20 12:13 EDT by Colin Walters
Modified: 2016-06-23 00:55 EDT (History)
14 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 00:55:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Disable-rsyslog-for-RHELAH-use.patch (1.50 KB, patch)
2015-10-21 11:01 EDT, Colin Walters
no flags Details | Diff

  None (edit)
Description Colin Walters 2015-10-20 12:13:39 EDT
We're looking at adding GlusterFS support to the base RHEL Atomic Host.  Right now, our recommended rsyslog configuration comes as a privileged container.

Yet, glusterfs-libs has:

Requires:         rsyslog-mmjsonparse

What is the rationale behind this?  Git annotate was not very helpful, I traced it to:

```
commit a4bca334ac07b498869e636f3bbab26009c962d7
Author:     Bala.FA <barumuga@redhat.com>
AuthorDate: Mon Oct 7 12:01:48 2013 +0530
Commit:     Bala.FA <barumuga@redhat.com>
CommitDate: Mon Oct 7 12:01:48 2013 +0530

    imported glusterfs-3.4.0.33rhs-1.el6rhs.src.rpm
    
    Resolves: bz#981054
    Signed-off-by: Bala.FA <barumuga@redhat.com>
```

And the linked bug doesn't say.
Comment 3 Colin Walters 2015-10-21 11:01 EDT
Created attachment 1085198 [details]
0001-Disable-rsyslog-for-RHELAH-use.patch
Comment 15 Stanislav Graf 2016-03-29 15:18:04 EDT
Is there any update?
Comment 16 Kaleb KEITHLEY 2016-04-25 08:11:30 EDT
upstream has eliminated the dep on rsyslog-mmjsonparse

barumuga@redhat.com had a needinfo, but he has left. Assigning and need-info to mchangir@redhat.com
Comment 17 Milind Changire 2016-04-27 13:31:59 EDT
I'm glad the dependency on rsyslog-mmjsonparse has been eliminated.
Comment 22 Atin Mukherjee 2016-05-31 04:14:55 EDT
Shouldn't this be marked as ON_QA now?
Comment 23 Milind Changire 2016-05-31 04:24:44 EDT
fix has been received from mainline during rebase to glusterfs v3.7.9
moving to ON_QA
Comment 24 Rahul Hinduja 2016-06-03 05:07:13 EDT
Tried by installing glusterfs client packages on RHEL7, it doesn't pull/depend on rsyslog even if rsyslog is present as part of other repos.
Comment 27 errata-xmlrpc 2016-06-23 00:55:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.