Bug 1273553 - TypeError: Must be string, not DASDDevice
TypeError: Must be string, not DASDDevice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
s390x Linux
high Severity high
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
AcceptedFreezeException
: Reopened
Depends On:
Blocks: ZedoraTracker F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-20 12:53 EDT by Jan Stodola
Modified: 2015-10-26 17:01 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-23.19.9-1 anaconda-23.19.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 17:01:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2015-10-20 12:53:49 EDT
Description of problem:
I got the following traceback when running kickstart installation in VNC mode on an s390x system with unformatted DASD disk:

anaconda 23.19.7-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/gi/overrides/BlockDev.py", line 395, in wrapped
    ret = orig_obj(*args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 710, in run_dasdfmt
    blockdev.s390.dasd_format(disk)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: Must be string, not DASDDevice


Version-Release number of selected component (if applicable):
http://s390pkgs.fedoraproject.org/compose/23_TC1/23/Server/s390x/os/
anaconda-23.19.7-1.fc23
python-blivet-1.12.7-1.fc23

How reproducible:
always

Steps to Reproduce:
1. have an unformatted DASD disk (or format one DASD disk with cpfmtxa in CMS)
2. start kickstart installation in VNC mode, the ks file contains:

vnc
bootloader --location=mbr
zerombr
clearpart --all --initlabel
autopart


Actual results:
anaconda traceback

Expected results:
unformatted DASD disk is formatted with dasdfmt and the installation finishes successfully
Comment 2 Samantha N. Bueno 2015-10-20 12:56:22 EDT
This is again a very easy (one-line) fix isolated strictly to s390x code.
Comment 3 Fedora Blocker Bugs Application 2015-10-20 13:08:37 EDT
Proposed as a Freeze Exception for 23-final by Fedora user jstodola using the blocker tracking app because:

 Violating the following criteria:

https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Unattended_installation
https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Disk_layouts

Proposing as an exception, since this is only happening on s390x (secondary architecture)
Comment 4 Samantha N. Bueno 2015-10-20 13:34:02 EDT
Posted patch for review; even if it is rejected as a FE it needs to still get fixed in master.
Comment 5 Adam Williamson 2015-10-20 13:46:21 EDT
+1 FE, critical issue for s390 and it's clearly restricted to the DASD path in the code. Patch is https://lists.fedorahosted.org/pipermail/anaconda-patches/2015-October/024925.html
Comment 6 Kevin Fenzi 2015-10-20 13:47:25 EDT
+1 FE.
Comment 7 Mike Ruckman 2015-10-20 14:04:49 EDT
+1 FE
Comment 8 Adam Williamson 2015-10-20 14:12:52 EDT
That's +3, accepted.
Comment 9 Samantha N. Bueno 2015-10-21 13:24:34 EDT
Thanks, guys.
Comment 10 Fedora Update System 2015-10-21 14:32:20 EDT
python-blivet-1.12.8-1.fc23 anaconda-23.19.9-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-da7ada8825
Comment 11 Jan Stodola 2015-10-23 01:50:18 EDT
It is fixed in anaconda-23.19.9-1.fc23, the installation finished successfully and an unformatted DASD was formatted with dasdfmt during the installation.
Thanks, moving to VERIFIED.
Comment 12 Fedora Update System 2015-10-24 08:08:53 EDT
anaconda-23.19.10-1.fc23, python-blivet-1.12.8-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update anaconda python-blivet'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-da7ada8825
Comment 13 Jan Stodola 2015-10-26 04:55:56 EDT
Closing as fixed (see comment 11).
Comment 14 Adam Williamson 2015-10-26 12:55:16 EDT
...except the update has not been pushed stable.
Comment 15 Fedora Update System 2015-10-26 17:00:45 EDT
anaconda-23.19.10-1.fc23, python-blivet-1.12.8-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.