This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1273568 - NPE on CreateCinderSnapshot - negative flow
NPE on CreateCinderSnapshot - negative flow
Status: CLOSED DUPLICATE of bug 1273572
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Daniel Erez
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 13:29 EDT by Daniel Erez
Modified: 2016-03-10 02:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 05:01:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
tnisan: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Daniel Erez 2015-10-20 13:29:36 EDT
Description of problem:
An NPE is thrown on negative flow of create cinder snapshot (CreateCinderSnapshotCommandCallback -> onFailed).

How reproducible:
100%

Steps to Reproduce:
1. Create a snapshot.
2. Cause a failure.
3.

Actual results:
NPE is thrown and the snapshot stays locked.

Expected results:
Proper rollback and cleanup.

Additional info:
Comment 1 Tal Nisan 2015-10-21 05:01:38 EDT

*** This bug has been marked as a duplicate of bug 1273572 ***

Note You need to log in before you can comment on or make changes to this bug.