Bug 1273598 - docker looses /etc/hosts
docker looses /etc/hosts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker-latest (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks: docker-1.10 1305185
  Show dependency treegraph
 
Reported: 2015-10-20 14:40 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 10:54:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2015-10-20 14:40:48 EDT
Description of problem:
https://github.com/docker/docker/issues/17190

Docker 1.8 has a race condition and can corrupt /etc/hosts inside a container 

Google is coordinating a temp fix for the distros since upstream is pushing the issue out to upstream 1.9 for a fix.


Expected results:


Additional info:
Comment 1 Daniel Walsh 2015-10-20 14:49:21 EDT
As soon as they have a fix, we can patch this, but I am not sure if we are releasing anything before we ship docker-1.9?
Comment 2 Daniel Walsh 2015-10-28 13:26:34 EDT
Looks like googles fix will be outside of docker.

So we can say this is partially fixed in docker-1.9. With more fixes coming in docker-1.10.
Comment 3 Daniel Walsh 2016-01-06 14:45:55 EST
Fixed in docker-1.10
Comment 5 Luwen Su 2016-02-03 04:29:54 EST
In docker-1.9.1-15.el7.x86_64,
use this https://github.com/docker/docker/issues/17190#issuecomment-149437458,
the file looks good
# docker exec test-master cat /etc/hosts
172.17.0.2	f988d8d83483
127.0.0.1	localhost
::1	localhost ip6-localhost ip6-loopback
fe00::0	ip6-localnet
ff00::0	ip6-mcastprefix
ff02::1	ip6-allnodes
ff02::2	ip6-allrouters
Comment 6 Lokesh Mandvekar 2016-02-03 10:53:20 EST
i'm moving this back to MODIFIED as per Dan's comment and scheduling this for 1.10 update.
Comment 9 Lokesh Mandvekar 2016-04-19 12:10:37 EDT
changing component to docker-latest
Comment 11 Alex Jia 2016-04-29 06:50:18 EDT
It works well on docker-latest-1.10.3-19, so moving the bug to VERIFIED status.
Comment 13 errata-xmlrpc 2016-05-12 10:54:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1057.html

Note You need to log in before you can comment on or make changes to this bug.