Bug 1273628 - SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'read' accesses on the file libpepflashplayer.so.
SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'read' accesses on the...
Status: CLOSED DUPLICATE of bug 1276931
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:29122db60bd11f3090e16e555b3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 15:45 EDT by edo
Modified: 2015-11-09 01:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 01:39:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description edo 2015-10-20 15:45:45 EDT
Description of problem:
SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'read' accesses on the file libpepflashplayer.so.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed read access on the libpepflashplayer.so file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                libpepflashplayer.so [ file ]
Source                        abrt-hook-ccpp
Source Path                   /usr/libexec/abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-addon-coredump-helper-2.6.1-6.fc22.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.18.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-200.fc22.x86_64 #1 SMP Thu
                              Oct 8 03:23:55 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-10-20 21:44:48 CEST
Last Seen                     2015-10-20 21:44:48 CEST
Local ID                      6fa4decc-3635-4adf-833b-b99b4faf5b79

Raw Audit Messages
type=AVC msg=audit(1445370288.481:1269): avc:  denied  { read } for  pid=5014 comm="abrt-hook-ccpp" name="libpepflashplayer.so" dev="dm-2" ino=17039948 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file permissive=1


type=AVC msg=audit(1445370288.481:1269): avc:  denied  { open } for  pid=5014 comm="abrt-hook-ccpp" path="/home/dodoedo/.config/google-chrome-beta/PepperFlash/19.0.0.226/libpepflashplayer.so" dev="dm-2" ino=17039948 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file permissive=1


type=SYSCALL msg=audit(1445370288.481:1269): arch=x86_64 syscall=open success=yes exit=ENXIO a0=55e87be91780 a1=0 a2=7ffd82cfe170 a3=141 items=0 ppid=5012 pid=5014 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-hook-ccpp exe=/usr/libexec/abrt-hook-ccpp subj=system_u:system_r:abrt_dump_oops_t:s0 key=(null)

Hash: abrt-hook-ccpp,abrt_dump_oops_t,config_home_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-128.18.fc22.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-200.fc22.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-09 01:39:42 EST

*** This bug has been marked as a duplicate of bug 1276931 ***

Note You need to log in before you can comment on or make changes to this bug.