Bug 1273635 - instack-undercloud: /var/log/ironic is missing after the undercloud was installed: openstack-ironic-conductor.service and openstack-ironic-api.service are down
instack-undercloud: /var/log/ironic is missing after the undercloud was insta...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: instack-undercloud (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: Liberty
Assigned To: John Trowbridge
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 16:22 EDT by Alexander Chuzhoy
Modified: 2016-04-18 02:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-ironic-4.2.0-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2015-10-20 16:22:22 EDT
instack-undercloud: /var/log/ironic is missing after the undercloud was installed: openstack-ironic-conductor.service and openstack-ironic-api.service are down


Environment:
instack-0.0.8-1.el7.noarch
instack-undercloud-2.1.3-1.el7.noarch


Steps to reproduce:

Install the undercloud with "openstack undercloud install"
Use the guide[1] and advance until (including) "baremetal import --json instackenv.json"

1. https://repos.fedorapeople.org/repos/openstack-m/rdo-manager-docs/liberty/basic_deployment/basic_deployment_cli.html


result:
Error contacting Ironic server: Error communicating with http://192.0.2.1:6385/ [Errno 111] Connection refused. Attempt 1 of 6
Error contacting Ironic server: Error communicating with http://192.0.2.1:6385/ [Errno 111] Connection refused. Attempt 2 of 6

Expected result:
The nodes should be registered with no errors.

Note:
openstack-ironic-conductor.service and openstack-ironic-api.service are down because of the missing /var/log/ironic directory.
Comment 1 John Trowbridge 2015-10-20 16:26:11 EDT
Fixed via packaging in openstack-ironic-4.2.0-2.el7
Comment 2 Alan Pevec 2015-10-20 17:36:45 EDT
In liberty-testing repo
http://buildlogs.centos.org/centos/7/cloud/x86_64/openstack-liberty/
Comment 3 Alexander Chuzhoy 2015-10-21 11:13:02 EDT
Verified:
Environment:
openstack-ironic-common-4.2.0-2.el7.noarch

The /var/log/ironic directory is there.
the mentioned services are up and running.

Note You need to log in before you can comment on or make changes to this bug.