Bug 1273642 - Can't grant users permission to promote a content view
Summary: Can't grant users permission to promote a content view
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-20 20:45 UTC by Justin Sherrill
Modified: 2019-09-25 21:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:19:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Justin Sherrill 2015-10-20 20:45:33 UTC
Description of problem:

When trying to create a role filter that allows a user to promote a content view, the current permission 'promote_or_remove_content_views' does that does not grant user access to the 'promote' button in the ui.


Version-Release number of selected component (if applicable):
6.1

How reproducible:
Always

Steps to Reproduce:
1.  Create a role with a filter with the resource "Content Views" and a permission "promote_or_remove_content_views" and "publish_content_views".
2.  Add another filter with resource "lifecycle_environments" and permission "promote_or_remove_content_views_to_environments"
3. Login as a user with this role and try to promote a content view

Actual results:
There is no button on the content view version list allowing promotion


Expected results:
User should be able to promote a content view.


Additional info:

Comment 2 Brad Buckingham 2015-12-22 18:21:57 UTC
The scenario appears to partially work on the upstream today:

Assuming that the user has the role/permissions mentioned in the initial description as well as the following:

- Filter resource: Content Views
  - Permissions: view_content_views

- Filter resource: Lifecycle Environments 
  - Permissions: view_lifecycle_environments

The user is able to access the 'Promote' button from Content -> Content Views -> [view] -> Versions.  They can then select an environment and initiate the promotion.

One issue that does remain is that the progress of the promotion is not accessible to the user as foreman_tasks/api/tasks/bulk_search is not allowed.

Comment 3 Brad Buckingham 2015-12-22 19:20:09 UTC
The issue noted in comment #2 related to bulk search can be addressed by adding the following additional filter/permission:

- Filter resource: Foreman tasks/task
  - Permission: view_foreman_tasks

Comment 4 Brad Buckingham 2016-01-06 20:06:17 UTC
This bug is currently aligned to Satellite 6.2.  Based on comments #2 and #3, the behavior appears to be working on the upstream; therefore, going to move this bug to POST for verification once the downstream branches are rebased.

Note: When running the same test against Satellite 6.1.5 an error is observed in the UI attempting the promotion.  The error there should look like:

Validation failed: Organization ids Invalid organizations selection, you must select at least one of yours

Comment 7 Jitendra Yejare 2016-05-04 06:52:44 UTC
Verified !

@Sat 6.2 Snap 9.3

The promote button is visible and also I am able to promote the CV version for the user with role having permissions promote_or_remove_content_views, publish_content_views and promote_or_remove_content_views_to_environments.

So moving this to verified.

Comment 9 errata-xmlrpc 2016-07-27 09:19:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.