Bug 127365 - Kernel does not compile from kernel-source
Summary: Kernel does not compile from kernel-source
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-07 05:35 UTC by Mindaugas Riauba
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-07 11:19:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mindaugas Riauba 2004-07-07 05:35:36 UTC
Description of problem:
Kernel compilation stops with errors.

Version-Release number of selected component (if applicable):
kernel-source-2.4.21-15.0.3.EL

How reproducible:
Every time

Steps to Reproduce:
1. up2date -if kernel-source
2. cd /usr/src/linux-2.4
3. make mrproper
4. cp configs/kernel-2.4.21-i686-hugemem.config .config
5. make menuconfig (and just leave)
6. make dep
7. make clean
8. make bzImage
9. make modules  

Actual results:
make -C aic7xxx modules
make[3]: Entering directory `/usr/src/linux-2.4.21-
15.0.3.EL/drivers/scsi/aic7xxx'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.21-15.0.3.EL/include -Wall -Wstrict-
prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common  -Wno-
unused -fomit-frame-pointer -pipe -freorder-blocks -mpreferred-stack-
boundary=2 -march=i686 -DMODULE -DMODVERSIONS -
include /usr/src/linux-2.4.21-15.0.3.EL/include/linux/modversions.h -
I/usr/src/linux-2.4.21-15.0.3.EL/drivers/scsi -Werror -nostdinc -iwithprefix 
include -DKBUILD_BASENAME=aic7xxx_osm  -c -o aic7xxx_osm.o 
aic7xxx_osm.c
cc1: warnings being treated as errors
In file included from /usr/src/linux-2.4.21-15.0.3.EL/include/linux/swap.h:6,
                 from /usr/src/linux-2.4.21-15.0.3.EL/include/linux/mm.h:31,
                 from /usr/src/linux-2.4.21-15.0.3.EL/include/linux/blkdev.h:9,
                 from /usr/src/linux-2.4.21-15.0.3.EL/include/linux/blk.h:4,
                 from aic7xxx_osm.h:63,
                 from aic7xxx_osm.c:122:
/usr/src/linux-2.4.21-15.0.3.EL/include/linux/brlock.h:88: warning: 
`always_inline' attribute directive ignored
/usr/src/linux-2.4.21-15.0.3.EL/include/linux/brlock.h:101: warning: 
`always_inline' attribute directive ignored
/usr/src/linux-2.4.21-15.0.3.EL/include/linux/brlock.h:171: warning: 
`always_inline' attribute directive ignored
/usr/src/linux-2.4.21-15.0.3.EL/include/linux/brlock.h:179: warning: 
`always_inline' attribute directive ignored
make[3]: *** [aic7xxx_osm.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.21-
15.0.3.EL/drivers/scsi/aic7xxx'
make[2]: *** [_modsubdir_aic7xxx] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.21-15.0.3.EL/drivers/scsi'
make[1]: *** [_modsubdir_scsi] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.21-15.0.3.EL/drivers'
make: *** [_mod_drivers] Error 2

Comment 1 Rik van Riel 2004-07-07 11:19:30 UTC
Instead of "make menuconfig" you'll want to run "make oldconfig" twice.

The reason for running it twice is that the config file shipped by Red
Hat is machine generated and the config language in the 2.4 kernel can
only resolve dependencies in one direction.

After that it should just compile.  It does here...

Comment 2 Mindaugas Riauba 2004-07-08 05:58:56 UTC
Sorry for false alarm. The problem was that Oracle install requires 
(http://www.puschitz.com/InstallingOracle9i.shtml#RunningOracleInstallationO
nRHELAS3) /usr/bin/gcc to be gcc 2.96 from compat-gcc. After I edited 
Makefile to use normal gcc compile succeded without any problems.


Note You need to log in before you can comment on or make changes to this bug.