Bug 1273653 - RFE: Automatic LVM partitioning should leave N (10?) % space for snapshots
RFE: Automatic LVM partitioning should leave N (10?) % space for snapshots
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 17:42 EDT by François Cami
Modified: 2015-10-22 20:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 20:04:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description François Cami 2015-10-20 17:42:08 EDT
Description of problem:
As it stands (or at least it was the case with F22 - I assume rawhide still behaves in the same way), the automatic LVM partitioning does not leave any space in VGs.
Since XFS filesystems' size cannot be reduced, only grown, this means that manual partitioning is mandatory if LVM snapshots are needed.

Version-Release number of selected component (if applicable):
Any.

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora with the default LVM partitioning selected.

Actual results:
The resulting VG is always full.

Expected results:
Get some space (10%?) reserved for snapshots. This space can be reclaimed (using lvresize and xfs_grow) easily post-install if needed.

Additional info:
This could replace the LVM partitioning scheme or be another partitioning scheme. BTRFS and LVM are available, maybe another scheme titled "LVM with spare space", ideally with the % of spare space as a configurable item.
Comment 1 François Cami 2015-10-20 17:54:33 EDT
Rationale:
"As a sysadmin, I need to run fsck on a snapshot of a live filesystem"
"As a sysadmin, I need to create consistent backups of a whole system"
"As a sysadmin, I want to snapshot the system before updating it"
Comment 2 Brian Lane 2015-10-22 20:04:22 EDT
The default covers what most users need. If you need something different you can use custom partitioning or a kickstart.

Note You need to log in before you can comment on or make changes to this bug.