Bug 1273661 - nordugrid-arc-python3 has python2 pyc files
nordugrid-arc-python3 has python2 pyc files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nordugrid-arc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mattias Ellert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 18:46 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2015-12-08 23:53 EST (History)
2 users (show)

See Also:
Fixed In Version: nordugrid-arc-5.0.4-1.fc23 nordugrid-arc-5.0.4-1.fc22 nordugrid-arc-5.0.4-1.el5 nordugrid-arc-5.0.4-1.el7 nordugrid-arc-5.0.4-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 12:51:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2015-10-20 18:46:42 EDT
$ dnf repoquery -l nordugrid-arc-python3-5.0.3-1.fc24.x86_64|grep 'python3.4.*py[co]$'|grep -v __pycache__
/usr/lib64/python3.4/site-packages/arc/__init__.pyc
/usr/lib64/python3.4/site-packages/arc/__init__.pyo
/usr/lib64/python3.4/site-packages/arc/common.pyc
/usr/lib64/python3.4/site-packages/arc/common.pyo
/usr/lib64/python3.4/site-packages/arc/communication.pyc
/usr/lib64/python3.4/site-packages/arc/communication.pyo
/usr/lib64/python3.4/site-packages/arc/compute.pyc
/usr/lib64/python3.4/site-packages/arc/compute.pyo
/usr/lib64/python3.4/site-packages/arc/credential.pyc
/usr/lib64/python3.4/site-packages/arc/credential.pyo
/usr/lib64/python3.4/site-packages/arc/data.pyc
/usr/lib64/python3.4/site-packages/arc/data.pyo
/usr/lib64/python3.4/site-packages/arc/delegation.pyc
/usr/lib64/python3.4/site-packages/arc/delegation.pyo
/usr/lib64/python3.4/site-packages/arc/loader.pyc
/usr/lib64/python3.4/site-packages/arc/loader.pyo
/usr/lib64/python3.4/site-packages/arc/message.pyc
/usr/lib64/python3.4/site-packages/arc/message.pyo
/usr/lib64/python3.4/site-packages/arc/security.pyc
/usr/lib64/python3.4/site-packages/arc/security.pyo

Version-Release number of selected component (if applicable):
nordugrid-arc-python3-5.0.3-1.fc24.x86_64

I don't think this can cause any problems, it's just confusing and a slight waste.
Comment 1 Mattias Ellert 2015-10-21 08:18:21 EDT
These files are actually python3 pyc file with the wrong name:

$ file /usr/lib64/python3.4/site-packages/arc/__init__.pyc
/usr/lib64/python3.4/site-packages/arc/__init__.pyc: python 3.4 byte-compiled

The reason is an old py-compile file in the sources (from RHEL6 where the source tarball was generated) that doesn't support python3 very well.
Comment 2 Fedora Update System 2015-11-23 12:10:28 EST
nordugrid-arc-doc-2.0.5-1.el6 nordugrid-arc-5.0.4-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-b22dc27475
Comment 3 Fedora Update System 2015-11-23 12:10:34 EST
nordugrid-arc-doc-2.0.5-1.fc22 nordugrid-arc-5.0.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7e72030dab
Comment 4 Fedora Update System 2015-11-23 12:10:35 EST
nordugrid-arc-doc-2.0.5-1.el7 nordugrid-arc-5.0.4-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-59ac22168e
Comment 5 Fedora Update System 2015-11-23 12:10:39 EST
nordugrid-arc-doc-2.0.5-1.el5 nordugrid-arc-5.0.4-1.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-a324643bea
Comment 6 Fedora Update System 2015-11-23 19:53:55 EST
nordugrid-arc-5.0.4-1.fc22, nordugrid-arc-doc-2.0.5-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update nordugrid-arc nordugrid-arc-doc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7e72030dab
Comment 7 Fedora Update System 2015-11-23 21:22:45 EST
nordugrid-arc-5.0.4-1.fc23, nordugrid-arc-doc-2.0.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update nordugrid-arc nordugrid-arc-doc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-673dcf4a36
Comment 8 Fedora Update System 2015-11-23 21:47:57 EST
nordugrid-arc-5.0.4-1.el5, nordugrid-arc-doc-2.0.5-1.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update nordugrid-arc nordugrid-arc-doc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-a324643bea
Comment 9 Fedora Update System 2015-11-23 21:49:16 EST
nordugrid-arc-5.0.4-1.el6, nordugrid-arc-doc-2.0.5-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update nordugrid-arc nordugrid-arc-doc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-b22dc27475
Comment 10 Fedora Update System 2015-11-23 21:49:45 EST
nordugrid-arc-5.0.4-1.el7, nordugrid-arc-doc-2.0.5-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update nordugrid-arc nordugrid-arc-doc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-59ac22168e
Comment 11 Fedora Update System 2015-12-01 12:51:49 EST
nordugrid-arc-5.0.4-1.fc23, nordugrid-arc-doc-2.0.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-12-01 14:49:45 EST
nordugrid-arc-5.0.4-1.fc22, nordugrid-arc-doc-2.0.5-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2015-12-08 22:27:14 EST
nordugrid-arc-5.0.4-1.el5, nordugrid-arc-doc-2.0.5-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2015-12-08 23:22:05 EST
nordugrid-arc-5.0.4-1.el7, nordugrid-arc-doc-2.0.5-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2015-12-08 23:53:03 EST
nordugrid-arc-5.0.4-1.el6, nordugrid-arc-doc-2.0.5-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.