This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1273689 - Creating internal snapshot fails with data-plane
Creating internal snapshot fails with data-plane
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Stefan Hajnoczi
FuXiangChun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 23:02 EDT by Pei Zhang
Modified: 2017-03-07 04:22 EST (History)
11 users (show)

See Also:
Fixed In Version: QEMU 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-07 15:47:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pei Zhang 2015-10-20 23:02:51 EDT
Description of problem:
Creating internal snapshot fails with data-plane.

Version-Release number of selected component (if applicable):
Host:
Kernel:3.10.0-325.el7.x86_64
qemu-kvm-rhev:qemu-kvm-rhev-2.3.0-31.el7.x86_64

Guest:
Kernel:3.10.0-325.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot guest with data-plane
# /usr/libexec/qemu-kvm -name rhel7.2 -machine pc-i440fx-rhel7.2.0,accel=kvm \
-cpu SandyBridge -m 4G,slots=256,maxmem=40G -numa node \
-smp 4,sockets=2,cores=2,threads=1 \
-uuid 82b1a01e-5f6c-4f5f-8d27-3855a74e6b61 \
-netdev tap,id=hostnet0 \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=12:54:00:5c:88:61 \
-device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16 \
-vnc 0.0.0.0:1 \
-monitor stdio \
-qmp tcp:0:5555,server,nowait \
-serial unix:/tmp/monitor,server,nowait \
-object iothread,id=iothread0 \
-drive file=/home/rhel7.2.virtio.qcow2,format=qcow2,if=none,id=drive-virtio-blk0,werror=stop,rerror=stop \
-device virtio-blk-pci,drive=drive-virtio-blk0,id=virtio-blk0,iothread=iothread0 \

2. Create internal snapshot. This job can not be finished(wait 30 miniutes).
(qemu) savevm

3. check the image info, no snapshot exists.
# qemu-img info /home/rhel7.2.virtio.qcow2 
image: /home/rhel7.2.virtio.qcow2
file format: qcow2
virtual size: 20G (21474836480 bytes)
disk size: 13G
cluster_size: 65536
Format specific information:
    compat: 1.1
    lazy refcounts: false
    refcount bits: 16
    corrupt: false


Actual results:
'(qemu) savevm' can not be finished even after 30 minutes.


Expected results:
'(qemu) savevm' should finish quickly and correctly.


Additional info:
1. Without data-plane, '(qemu) savevm' will be finished with 5 seconds.
Comment 3 Stefan Hajnoczi 2016-06-03 18:56:23 EDT
Fixed in RHEL 7.3 qemu-kvm-rhev due to upstream QEMU 2.6 rebased.  Denis Lunev fixed migration/savevm.c.

I tested qemu-kvm-rhev-2.6.0-4.el7.
Comment 5 Yumei Huang 2016-09-13 03:10:40 EDT
Reproduce:
qemu-kvm-rhev-2.3.0-31.el7
kernel-3.10.0-505.el7.x86_64

Boot guest with virtio-blk data-plane, do savevm in qmp. Both guest and qmp become unresponsive.  And no snapshot is generated.

Steps:
1. # /usr/libexec/qemu-kvm -m 1024,slots=10,maxmem=32G -smp 8 -cpu host  \

 -object iothread,id=iothread0  -drive id=drive_image1,if=none,snapshot=off,aio=native,cache=none,format=qcow2,file=/home/guest/rhel73.qcow2 -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pci.0,addr=04,iothread=iothread0  \

-device e1000,mac=9a:65:66:67:68:69,id=id9yQ73x,netdev=idT9phLU,bus=pci.0,addr=05 -netdev tap,id=idT9phLU -usb -device usb-tablet,id=usb-tablet1 -vga cirrus -vnc :0 -monitor stdio

2. (qemu) savevm    // no response 

3. # qemu-img info rhel73.qcow2       
image: rhel73.qcow2
file format: qcow2
virtual size: 40G (42949672960 bytes)
disk size: 8.3G
cluster_size: 65536
Format specific information:
    compat: 1.1
    lazy refcounts: false
    refcount bits: 16
    corrupt: false


Verify:
qemu-kvm-rhev-2.6.0-24.el7
kernel-3.10.0-505.el7.x86_64

With same steps as above, a snapshot has been generated successfully and guest works well. 

#  qemu-img info rhel73.qcow2 
image: rhel73.qcow2
file format: qcow2
virtual size: 40G (42949672960 bytes)
disk size: 9.1G
cluster_size: 65536
Snapshot list:
ID        TAG                 VM SIZE                DATE       VM CLOCK
1         vm-20160913030723      838M 2016-09-13 03:07:23   00:01:51.988
Format specific information:
    compat: 1.1
    lazy refcounts: false
    refcount bits: 16
    corrupt: false

So the bug is fixed.
Comment 7 errata-xmlrpc 2016-11-07 15:47:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html

Note You need to log in before you can comment on or make changes to this bug.