This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1273700 - Malformed RDN check should happen at begin of IPA installation
Malformed RDN check should happen at begin of IPA installation
Status: CLOSED DUPLICATE of bug 1278330
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 01:09 EDT by Abhijeet Kasurde
Modified: 2015-11-05 04:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 04:55:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ipa-server-install.log (3.86 KB, text/plain)
2015-10-21 01:12 EDT, Abhijeet Kasurde
no flags Details
console.log (1.50 KB, text/plain)
2015-10-21 01:13 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Abhijeet Kasurde 2015-10-21 01:09:29 EDT
Description of problem:
IPA installation should check Relative Distinguished Name (RDN) before installation rather than failing after process start

ipa-server-install --setup-dns --forwarder=10.16.36.29  -r TESTRELM.TEST -p Secret123 -a Secret123 --subject=NOSUBJECT -U

<snip>

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Warning: skipping DNS resolution of host ipaserver.testrelm.test
The domain name has been determined based on the host name.

Checking DNS forwarders, please wait ...
Using reverse zone(s) 121.65.10.in-addr.arpa.

The IPA Master Server will be configured with:
Hostname:       ipaserver.testrelm.test
IP address(es): 10.65.121.12
Domain name:    testrelm.test
Realm name:     TESTRELM.TEST

BIND DNS server will be configured to serve IPA domain with:
Forwarders:    10.16.36.29
Reverse zone(s):  121.65.10.in-addr.arpa.

Configuring NTP daemon (ntpd)
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
ipa.ipapython.install.cli.install_tool(Server): ERROR    malformed RDN string = "NOSUBJECT"




Version-Release number of selected component (if applicable):
ipa-server-4.2.0-15.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start fresh installation of IPA server with invalid RDN as subject argument.

Actual results:
Error message after installation process
ipa.ipapython.install.cli.install_tool(Server): ERROR    malformed RDN string = "NOSUBJECT"

Expected results:
Error message before installation starts with informative/warning message to user rather than "malformed RDN string"
Comment 1 Abhijeet Kasurde 2015-10-21 01:12 EDT
Created attachment 1084976 [details]
ipa-server-install.log
Comment 2 Abhijeet Kasurde 2015-10-21 01:13 EDT
Created attachment 1084977 [details]
console.log
Comment 4 Petr Vobornik 2015-10-22 04:25:14 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5392
Comment 6 Petr Vobornik 2015-11-05 04:55:46 EST

*** This bug has been marked as a duplicate of bug 1278330 ***

Note You need to log in before you can comment on or make changes to this bug.