Bug 1273702 - man-pages causes a file conflict with old attr package
Summary: man-pages causes a file conflict with old attr package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: man-pages
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nikola Forró
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: upgrade-conflicts
TreeView+ depends on / blocked
 
Reported: 2015-10-21 05:18 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2015-11-01 02:30 UTC (History)
3 users (show)

Fixed In Version: man-pages-4.00-5.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-01 02:30:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2015-10-21 05:18:06 UTC
$ dnf system-upgrade download --releasever=23
...
Error: Transaction check error:
  file /usr/share/man/man5/attr.5.gz from install of man-pages-4.00-4.fc23.noarch conflicts with file from package attr-2.4.47-10.fc22.x86_64

man-pages should conflict with version of attr less than the one in which attr.5.gz was removed (Conflicts: attr < 2.4.47-14 is probably fine). This is a problem because the conflict is detected too late, in the transaction check phase.

Version-Release number of selected component (if applicable):
man-pages-3.81-3.fc22.noarch
attr-2.4.47-10.fc22.x86_64

Comment 1 Nikola Forró 2015-10-21 12:44:25 UTC
The only way I'm able to reproduce this is when I exclude attr package from being updated in dnf.conf. If I don't do that, both packages are updated, so there is no conflict:

attr-2.4.47-10.fc22 -> attr-2.4.47-14.fc23
man-pages-3.81-3.fc22 -> man-pages-4.00-4.fc23

Can you provide more information (dnf logs)?

Comment 2 Zbigniew Jędrzejewski-Szmek 2015-10-21 13:49:30 UTC
One way to encounter this is to have a failed upgrade with more than one version of the package installed. Another would be to have both attr.x86_64 and attr.i686 installed and attempt to upgrade just one of them. You are right that this is not something that would be normally encountered, but having proper conflicts helps: instead of having to manually remove packages and resolve the conflict, the system would uninstall the conflicting package and the problem would be resolved automatically.

Comment 3 Fedora Update System 2015-10-22 10:15:52 UTC
man-pages-4.00-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4d56cdd503

Comment 5 Fedora Update System 2015-10-24 12:07:43 UTC
man-pages-4.00-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update man-pages'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4d56cdd503

Comment 6 Fedora Update System 2015-11-01 02:30:13 UTC
man-pages-4.00-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.