Bug 1273707 - Invalid subject fails IPA installation
Invalid subject fails IPA installation
Status: CLOSED DUPLICATE of bug 1278330
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 01:38 EDT by Abhijeet Kasurde
Modified: 2015-11-05 04:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 04:55:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console.log (4.95 KB, text/plain)
2015-10-21 01:43 EDT, Abhijeet Kasurde
no flags Details
ipaserver-install.log (780.79 KB, text/plain)
2015-10-21 01:45 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Abhijeet Kasurde 2015-10-21 01:38:00 EDT
Description of problem:
If user specify subject CN= in IPA server installation, then installation fails with  `CA did not start in 300.0s` error

# ipa-server-install --setup-dns --forwarder=10.16.36.29  -r TESTRELM.TEST -p xxxxxxxxx -a xxxxxxxxx --subject CN=Test -U

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-15.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. ipa-server-install --setup-dns --forwarder=10.16.36.29  -r TESTRELM.TEST -p xxxxxxxxx -a xxxxxxxxx --subject CN=Test -U

Actual results:
Installation fails with error `CA did not start in 300.0s`

Expected results:
Installation should check subject argument before installation start
Comment 1 Abhijeet Kasurde 2015-10-21 01:43 EDT
Created attachment 1084982 [details]
console.log
Comment 2 Abhijeet Kasurde 2015-10-21 01:45 EDT
Created attachment 1084985 [details]
ipaserver-install.log
Comment 4 Petr Vobornik 2015-10-22 04:24:14 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5391
Comment 6 Petr Vobornik 2015-11-05 04:55:17 EST

*** This bug has been marked as a duplicate of bug 1278330 ***

Note You need to log in before you can comment on or make changes to this bug.