Bug 1273757 - Diagnostics don't show warning message when atomic-openshift-node/openswitch service stopped.
Diagnostics don't show warning message when atomic-openshift-node/openswitch ...
Status: CLOSED NEXTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 04:03 EDT by Anping Li
Modified: 2015-11-10 14:20 EST (History)
4 users (show)

See Also:
Fixed In Version: atomic-openshift-3.0.2.905-0.git.0.85d6f88.el7aos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 14:20:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2015-10-21 04:03:16 EDT
Description of problem:
Stop atomic-openshift-node and openvswitch on node. diagnostics doesn't report warning messages. It should give message as we stopped docker service.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. systemctl stop atomic-openshift-node, then run openshift ex diagnostics  --node-config=/etc/origin/node/node-config.yaml 
2. systemctl stop openvswitch, then run openshift ex diagnostics  --node-config=/etc/origin/node/node-config.yaml 


Expected Result:
1 No error was reported
openshift ex diagnostics  --node-config=/etc/origin/node/node-config.yaml 
[Note] Determining if client configuration exists for client/cluster diagnostics
[Note] No client configuration specified; skipping client and cluster diagnostics.
[Note] Performing systemd discovery

[Note] Running diagnostic: AnalyzeLogs
       Description: Check for recent problems in systemd service logs
       
Info:  Checking journalctl logs for 'docker' service
Info:  Checking journalctl logs for 'openvswitch' service

[Note] Running diagnostic: NodeConfigCheck
       Description: Check the node config file
       
Info:  Found a node config file: /etc/origin/node/node-config.yaml

[Note] Running diagnostic: UnitStatus
       Description: Check status for related systemd units
       
[Note] Summary of diagnostics execution (version v3.0.2.901-61-g568adb6):
[Note] Completed with no errors or warnings seen.

2 No error was reported
openshift ex diagnostics  --node-config=/etc/origin/node/node-config.yaml 
[Note] Determining if client configuration exists for client/cluster diagnostics
[Note] No client configuration specified; skipping client and cluster diagnostics.
[Note] Performing systemd discovery

[Note] Running diagnostic: AnalyzeLogs
       Description: Check for recent problems in systemd service logs
       
Info:  Checking journalctl logs for 'docker' service

[Note] Running diagnostic: NodeConfigCheck
       Description: Check the node config file
       
Info:  Found a node config file: /etc/origin/node/node-config.yaml

[Note] Running diagnostic: UnitStatus
       Description: Check status for related systemd units
       
[Note] Summary of diagnostics execution (version v3.0.2.901-61-g568adb6):
[Note] Completed with no errors or warnings seen.


Expected Result:

diagnostics show error/warning message when atomic-openshift-node  or openvswitch stopped
Comment 1 Luke Meyer 2015-10-21 12:52:24 EDT
systemd unit names have changed so diagnostics needs to follow the new names. It doesn't "know" there is a node running and won't read node logs either.
Comment 2 Luke Meyer 2015-10-30 16:42:46 EDT
Should be fixed once https://github.com/openshift/origin/pull/5524 merges and is built in OSE.
Comment 4 Anping Li 2015-11-02 01:05:10 EST
diagnostics reports Error Message as below now. So move bug to verified.

ERROR: [DS3001 from diagnostic UnitStatus@openshift/origin/pkg/diagnostics/systemd/unit_status.go:43]
       The atomic-openshift-node systemd unit is intended to start at boot but is not currently active.
       An administrator can start the atomic-openshift-node unit with:
       
         # systemctl start atomic-openshift-node
       
       To ensure it is not failing to run, check the status and logs with:
       
         # systemctl status atomic-openshift-node
         # journalctl -ru atomic-openshift-node
Comment 5 Luke Meyer 2015-11-10 14:20:07 EST
Unless I'm mistaken, this bug was never shipped (as the unit name changes ship with 3.1).

Note You need to log in before you can comment on or make changes to this bug.