Bug 1273772 - Fibre Channel (fc) does not recoginized as a valid volume type.
Fibre Channel (fc) does not recoginized as a valid volume type.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Storage (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mark Turansky
Liang Xia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 04:23 EDT by Liang Xia
Modified: 2015-11-23 16:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:17:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liang Xia 2015-10-21 04:23:54 EDT
Description of problem:
Trying to create a Persistent Volumes with Fibre Channel,
but fc does not recogized as a valid volume type.

Version-Release number of selected component (if applicable):
openshift v1.0.6-702-g16849ae
kubernetes v1.1.0-alpha.1-653-g86b4e77

How reproducible:
Always

Steps to Reproduce:
1. Setup openshift cluster with latest code.
2. Create pv with Fibre Channel.
# oc create -f https://raw.githubusercontent.com/openshift/origin/master/examples/wordpress/fc/pv-1.yaml

Actual results:
# oc create -f https://raw.githubusercontent.com/openshift/origin/master/examples/wordpress/fc/pv-1.yaml --config=openshift.local.config/master/admin.kubeconfig 
The PersistentVolume "pv0001" is invalid.
: invalid value '{GCEPersistentDisk:<nil> AWSElasticBlockStore:<nil> HostPath:<nil> Glusterfs:<nil> NFS:<nil> RBD:<nil> ISCSI:<nil> Cinder:<nil> CephFS:<nil>}', Details: exactly 1 volume type is required

Expected results:
PV created successfully.

Additional info:
The same command works on kubernetes.
Client Version: version.Info{Major:"1", Minor:"2+", GitVersion:"v1.2.0-alpha.2.90+360d0e0a7e92dc", GitCommit:"360d0e0a7e92dcc4d00b4c555e166a2a71a7e713", GitTreeState:"clean"}
Server Version: version.Info{Major:"1", Minor:"2+", GitVersion:"v1.2.0-alpha.2.90+360d0e0a7e92dc", GitCommit:"360d0e0a7e92dcc4d00b4c555e166a2a71a7e713", GitTreeState:"clean"}
Comment 1 hchen 2015-10-23 09:17:43 EDT
You are right on the spot. FC landed in k8s 1.2.0-alpha.2. Your Openshift is a few rev behind to catch that feature
Comment 2 Liang Xia 2015-10-26 01:38:52 EDT
Checked on below version, FC can be created now.

Please help to move it to ON_QA, so we can move it to verified. Thanks.

# openshift version
openshift v1.0.6-946-g5954394
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

# oc create -f https://raw.githubusercontent.com/openshift/origin/master/examples/wordpress/fc/pv-1.yaml --config=/root/openshift.local.config/master/admin.kubeconfig 
persistentvolume "pv0001" created

# oc get pv --config=/root/openshift.local.config/master/admin.kubeconfig
NAME             LABELS    CAPACITY   ACCESSMODES   STATUS      CLAIM                         REASON    AGE
pv0001           <none>    1Gi        RWO           Available                                           10s

# oc describe pv pv0001 --config=/root/openshift.local.config/master/admin.kubeconfig
Name:		pv0001
Labels:		<none>
Status:		Available
Claim:		
Reclaim Policy:	Retain
Access Modes:	RWO
Capacity:	1Gi
Message:	
Source:
Comment 3 hchen 2015-10-26 09:22:33 EDT
Your kubernetes version is 1.2.0-alpha.1, you need Kubernetes 1.2.0-alpha.2 to get FC support. 

See commit history at https://github.com/kubernetes/kubernetes/commit/ed9a1bbd3a9b689f4953deb6308d631314edf3f4
Comment 4 Liang Xia 2015-10-26 19:51:46 EDT
This bug track FibreChannel PV creation in origin, based on #comment 2, this has been fixed since PV can be created in origin now.

FC support (as in #comment 3) need Kubernetes 1.2.0-alpha.2,
we have to wait for origin's re-base since the current one is:
openshift v1.0.6-964-g814c05e
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2
and we will track it in bug 1275166

So move this bug to verified.

Note You need to log in before you can comment on or make changes to this bug.