Bug 1273789 - Do not initialize disabled extensions
Do not initialize disabled extensions
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Tools.Extensions (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Alon Bar-Lev
Ondra Machacek
infra
: CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 04:52 EDT by Alon Bar-Lev
Modified: 2016-02-10 14:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:17:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
alonbl: ovirt‑3.6.z?
alonbl: planning_ack?
alonbl: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47564 master MERGED exttool: do not initialize disabled extensions Never
oVirt gerrit 47597 ovirt-engine-3.6 MERGED exttool: do not initialize disabled extensions Never

  None (edit)
Description Alon Bar-Lev 2015-10-21 04:52:44 EDT
2015-10-21 10:36:22 SEVERE  Extension 'null' initialization failed (ignored): null
2015-10-21 10:36:22 FINE    Exception:
java.lang.NullPointerException
        at java.util.concurrent.ConcurrentHashMap.hash(ConcurrentHashMap.java:333)
        at java.util.concurrent.ConcurrentHashMap.get(ConcurrentHashMap.java:988)
        at org.ovirt.engine.core.extensions.mgr.ExtensionsManager.initialize(ExtensionsManager.java:309)
        at org.ovirt.engine.exttool.core.ExtensionsToolExecutor.loadExtensions(ExtensionsToolExecutor.java:144)
        at org.ovirt.engine.exttool.core.ExtensionsToolExecutor.main(ExtensionsToolExecutor.java:101)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.jboss.modules.Module.run(Module.java:312)
        at org.jboss.modules.Main.main(Main.java:473)
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-21 04:52:50 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Ondra Machacek 2015-11-26 05:23:54 EST
[root@om-ovirt36 ~]# rpm -q rhevm-backend
rhevm-backend-3.6.1-0.2.el6.noarch

[root@om-ovirt36 ~]# ovirt-engine-extensions-tool aaa search --extension-name=ad2008-authz --entity-name=user*
...
2015-11-26 11:18:15 FINE    Loading extension file 'ad2008-authz.properties'
2015-11-26 11:18:15 FINE    Extension file 'ad2008-authz.properties' disabled
2015-11-26 11:18:15 FINE    Loading extension file 'ad2008-authn.properties'
2015-11-26 11:18:15 FINE    Extension file 'ad2008-authn.properties' disabled
...

[root@om-ovirt36 ~]# echo $?
1
Comment 3 Sandro Bonazzola 2015-12-16 07:17:37 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.