Bug 1273827 - Creating smart variable with period or special character makes smart variable not to view, edit and delete.
Summary: Creating smart variable with period or special character makes smart variable...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1278718
TreeView+ depends on / blocked
 
Reported: 2015-10-21 10:52 UTC by Jitendra Yejare
Modified: 2019-09-25 21:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:58:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot Attached. (116.97 KB, image/png)
2015-10-21 10:52 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 12231 None None None 2016-04-22 16:10:11 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jitendra Yejare 2015-10-21 10:52:48 UTC
Created attachment 1085086 [details]
Screenshot Attached.

Description of problem:
In Smart Class-> Smart Variables tab, Creating smart variable with name having period or special character makes smart variable not to view, edit and delete.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201510151605git8893c3b.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a smart variable from tab Configure -> Classes-> smart class -> Smart variables tab with name having period or special character in it.

Actual results:
Smart variable with period or special character makes smart variable not to view, edit and delete.

Expected results:
Smart Variable with period or special character should be able to view, edit or delete from Configure -> Classes-> smart class -> Smart variables tab.

Additional info:
I am able to view, edit or delete the same smart variable(created with period or special characters) from Configure -> Smart Variables.

Comment 2 Tomer Brisker 2015-10-28 09:23:13 UTC
Connecting redmine issue http://projects.theforeman.org/issues/12231 from this bug

Comment 3 Bryan Kearney 2015-10-28 10:04:17 UTC
Upstream bug component is Provisioning

Comment 5 Bryan Kearney 2015-11-03 11:04:02 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12231 has been closed
-------------
Anonymous
Applied in changeset commit:51c05864e034d229efe4a4673ec85189da60e90c.

Comment 6 Jitendra Yejare 2016-01-27 12:45:51 UTC
Tested this issue in latest upstream.

I can create a smart variable with period character and special chars. Is that an expected behaviour ?

Build: foreman-1.11.0-0.develop.201601251557git59dc77b.el6.noarch

Comment 9 Jitendra Yejare 2016-04-13 13:20:18 UTC
As per discussion with Dev, To verify this feature we need hammer 0.6 which is not yet available in downstream. (Current Sat 6 snap 7.1)

Comment 10 Jitendra Yejare 2016-04-20 09:42:00 UTC
Verified in Sat 6.2 snap 8.2

I can create, edit and delete a smart variable with special char and period char in Configure -> Classes -> class_name -> Smart Variables.

So moving this to Verified.

Comment 12 errata-xmlrpc 2016-07-27 08:58:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.