Bug 1273845 - kernel: Use after free in ep_remove_wait_queue
kernel: Use after free in ep_remove_wait_queue
Status: CLOSED DUPLICATE of bug 1282688
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20150910,repor...
: Security
Depends On:
Blocks: 1273846
  Show dependency treegraph
 
Reported: 2015-10-21 07:44 EDT by Adam Mariš
Modified: 2015-11-17 23:34 EST (History)
34 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 23:34:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Mariš 2015-10-21 07:44:31 EDT
A use-after-free vulnerability causing memory corruption was found in kernel.

Reproducer with report can be found here:

https://groups.google.com/forum/#!topic/syzkaller/3twDUI4Cpm8

Patch can be found here:

http://article.gmane.org/gmane.linux.kernel/2057498
Comment 1 Josh Boyer 2015-10-21 08:45:34 EDT
The patches don't compile and there's still on-going discussion on the correct solution.  I believe we're waiting for Jason to send a v5 of the series.

Note You need to log in before you can comment on or make changes to this bug.