This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1273850 - Replica pairs in a volume shouldn't be from the same node
Replica pairs in a volume shouldn't be from the same node
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Luis Pabón
Anush Shetty
: ZStream
Depends On:
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-10-21 08:04 EDT by Anush Shetty
Modified: 2016-11-08 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version: heketi-1.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:44:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-10-21 08:04:26 EDT
Description of problem: During volume creation, there is a chance that heketi picks up replica pairs from the same node. This is not a supported RHGS configuration. 


Version-Release number of selected component (if applicable): 1.0.0


How reproducible: Always


Steps to Reproduce:
1. Run heketi server
2. Run heketi client to add nodes and devices
3. Create a volume 

Actual results:

Volume with replica pairs within the same node:

Eg. 

Volume Name: vol_f34cf8f3639e6d3a5106d97f8932ec9e
Type: Distributed-Replicate
Volume ID: 9af38984-2b03-4f1e-8691-bf51ad02ac44
Status: Started
Number of Bricks: 4 x 2 = 8
Transport-type: tcp
Bricks:
Brick1: rhshdp05.lab.eng.blr.redhat.com:/var/lib/heketi/mounts/vg_2cd66665852c51bbead1eb76f3b337ad/brick_18dce73c25f8d25fdaca8cff95fb583d/brick
Brick2: rhshdp06.lab.eng.blr.redhat.com:/var/lib/heketi/mounts/vg_546ec7767ff0e27137f56e1c8fb08d61/brick_7fe705e7f45ed1e640b0deb614f59c1f/brick
Brick3: rhshdp06.lab.eng.blr.redhat.com:/var/lib/heketi/mounts/vg_90b022ca94d670b60c16618cb60c73a8/brick_c5e9c2cbcd1579319853360ad9f37951/brick
Brick4: rhshdp05.lab.eng.blr.redhat.com:/var/lib/heketi/mounts/vg_2cd66665852c51bbead1eb76f3b337ad/brick_7bea69193e30120ef2a573535523c0d5/brick
Brick5: rhshdp05.lab.eng.blr.redhat.com:/var/lib/heketi/mounts/vg_2cd66665852c51bbead1eb76f3b337ad/brick_13d3c30116787a45d8a08d5108ef4662/brick
Brick6: rhshdp06.lab.eng.blr.redhat.com:/var/lib/heketi/mounts/vg_546ec7767ff0e27137f56e1c8fb08d61/brick_a8e987488d27d8f498e552f9a80b3f73/brick
Brick7: rhshdp06.lab.eng.blr.redhat.com:/var/lib/heketi/mounts/vg_90b022ca94d670b60c16618cb60c73a8/brick_12691ce59b5a4db67943b064d6b8a311/brick
Brick8: rhshdp06.lab.eng.blr.redhat.com:/var/lib/heketi/mounts/vg_546ec7767ff0e27137f56e1c8fb08d61/brick_4280c648fa95979b3579d30ba8f0b223/brick
Comment 2 Luis Pabón 2015-10-21 10:37:59 EDT
Github Issue: https://github.com/heketi/heketi/issues/231
Comment 5 Anush Shetty 2015-11-18 06:41:04 EST
Verified with heketi-1.0.1-1.el7rhgs.x86_64
Comment 7 errata-xmlrpc 2016-03-01 00:44:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.